<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><title>Create iptables Rules Based on Hostname Using IP Sets - Putorius</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%2C400italic%2C700italic%7CMontserrat%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2Cregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&#038;subset=latin&#038;display=swap" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="https://www.putorius.net/wp-content/cache/min/1/097049bb687b40e9bec29b3a0e481e88.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="description" content="Learn how to use IP Sets and a simple Bash script to update your iptables rules based on a clients hostname or domain name instead of IP address." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.putorius.net/ipset-iptables-rules-for-hostname.html" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Create iptables Rules Based on Hostname Using IP Sets - Putorius" /><meta property="og:description" content="Learn how to use IP Sets and a simple Bash script to update your iptables rules based on a clients hostname or domain name instead of IP address." /><meta property="og:url" content="https://www.putorius.net/ipset-iptables-rules-for-hostname.html" /><meta property="og:site_name" content="Putorius" /><meta property="article:publisher" content="https://www.facebook.com/putorius.net" /><meta property="article:published_time" content="2020-07-27T23:21:45+00:00" /><meta property="article:modified_time" content="2020-07-27T23:24:26+00:00" /><meta property="og:image" content="https://www.putorius.net/wp-content/uploads/2019/01/featured-min.jpg" /><meta property="og:image:width" content="1919" /><meta property="og:image:height" content="1076" /><meta property="fb:app_id" content="292441191418366" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@CuriousPutorius" /><meta name="twitter:site" content="@CuriousPutorius" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.putorius.net/#organization","name":"Putorius","url":"https://www.putorius.net/","sameAs":["https://www.facebook.com/putorius.net","https://www.youtube.com/channel/UCV9kD9xTuORCE9TDxHwY1uQ","https://twitter.com/CuriousPutorius"],"logo":{"@type":"ImageObject","@id":"https://www.putorius.net/#logo","inLanguage":"en-US","url":"https://www.putorius.net/wp-content/uploads/2019/01/logo-only-min.png","width":800,"height":800,"caption":"Putorius"},"image":{"@id":"https://www.putorius.net/#logo"}},{"@type":"WebSite","@id":"https://www.putorius.net/#website","url":"https://www.putorius.net/","name":"Putorius","description":"Linux Tutorials, How-tos, and General Information.","publisher":{"@id":"https://www.putorius.net/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.putorius.net/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.putorius.net/ipset-iptables-rules-for-hostname.html#primaryimage","inLanguage":"en-US","url":"https://www.putorius.net/wp-content/uploads/2020/02/Putorius-Feature-Default.jpg","width":1200,"height":700},{"@type":"WebPage","@id":"https://www.putorius.net/ipset-iptables-rules-for-hostname.html#webpage","url":"https://www.putorius.net/ipset-iptables-rules-for-hostname.html","name":"Create iptables Rules Based on Hostname Using IP Sets - Putorius","isPartOf":{"@id":"https://www.putorius.net/#website"},"primaryImageOfPage":{"@id":"https://www.putorius.net/ipset-iptables-rules-for-hostname.html#primaryimage"},"datePublished":"2020-07-27T23:21:45+00:00","dateModified":"2020-07-27T23:24:26+00:00","description":"Learn how to use IP Sets and a simple Bash script to update your iptables rules based on a clients hostname or domain name instead of IP address.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.putorius.net/ipset-iptables-rules-for-hostname.html"]}]},{"@type":"NewsArticle","@id":"https://www.putorius.net/ipset-iptables-rules-for-hostname.html#article","isPartOf":{"@id":"https://www.putorius.net/ipset-iptables-rules-for-hostname.html#webpage"},"author":{"@id":"https://www.putorius.net/#/schema/person/30abaceb4792405d8b52479085fd46d8"},"headline":"Create iptables Rules Based on Hostname Using IP Sets","datePublished":"2020-07-27T23:21:45+00:00","dateModified":"2020-07-27T23:24:26+00:00","mainEntityOfPage":{"@id":"https://www.putorius.net/ipset-iptables-rules-for-hostname.html#webpage"},"commentCount":0,"publisher":{"@id":"https://www.putorius.net/#organization"},"image":{"@id":"https://www.putorius.net/ipset-iptables-rules-for-hostname.html#primaryimage"},"keywords":"firewall,iptables","articleSection":"Linux Tutorials,Security","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.putorius.net/ipset-iptables-rules-for-hostname.html#respond"]}],"copyrightYear":"2020","copyrightHolder":{"@id":"https://www.putorius.net/#organization"}},{"@type":["Person"],"@id":"https://www.putorius.net/#/schema/person/30abaceb4792405d8b52479085fd46d8","name":"Marco Cherisi","description":"Marco Cherisi is a Linux and Android enthusiast and lover of all things tech.\u00a0 Marco holds Bachelor's Degree in Computer Science as well as several certifications in Linux and Cyber Security.\u00a0 Aside from his love of technology, Marco likes to fish, cook and play soccer.\u00a0 He occasionally likes to disconnect and go on long hikes with his dog Arturo."}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//fonts.gstatic.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Putorius &raquo; Feed" href="https://www.putorius.net/feed" /><link rel="alternate" type="application/rss+xml" title="Putorius &raquo; Comments Feed" href="https://www.putorius.net/comments/feed" /><link rel="alternate" type="application/rss+xml" title="Putorius &raquo; Create iptables Rules Based on Hostname Using IP Sets Comments Feed" href="https://www.putorius.net/ipset-iptables-rules-for-hostname.html/feed" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><style id='gillion-responsive-inline-css' type='text/css'></style> <script type='text/javascript' src='https://www.putorius.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript'>/* <![CDATA[ */ var gillion_loadmore_posts = {"ajax_url":"https:\/\/www.putorius.net\/wp-admin\/admin-ajax.php"};
var gillion = {"siteurl":"https:\/\/www.putorius.net\/","loggedin":"","page_loader":"0","notice":"enable","header_animation_dropdown_delay":"1000","header_animation_dropdown":"easeOutQuint","header_animation_dropdown_speed":"300","lightbox_opacity":"0.88","lightbox_transition":"elastic","page_numbers_prev":"Previous","page_numbers_next":"Next","rtl_support":"","footer_parallax":"","social_share":"\"\"","text_show_all":"Show All"}; /* ]]> */</script> <link rel='https://api.w.org/' href='https://www.putorius.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.putorius.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.putorius.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://www.putorius.net/?p=6036' /><link rel="preload" as="font" href="https://www.putorius.net/wp-content/themes/gillion/fonts/themify.woff" crossorigin><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." /><link rel="amphtml" href="https://www.putorius.net/ipset-iptables-rules-for-hostname.html/amp"><link rel="icon" href="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-180x180.png" /><meta name="msapplication-TileImage" content="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-270x270.png" /><style type="text/css" id="wp-custom-css">body{background:url(https://putorius.net/wp-content/uploads/2020/01/tesoro-putorius.jpg.webp) bottom right no-repeat fixed}#sidebar .theiaStickySidebar{position:static!important;transform:none!important}.container.sh-header-additional{padding:1!important}.sh-header-banner-container br{display:none}body #page-container a.post-title h2{font-size:22px}.sh-header-mobile-dropdown{top:-21px}pre{background:rgba(232,232,232,1);color:rgba(0,0,0,1);border-top-left-radius:0;border-bottom-left-radius:0;border-top-right-radius:10px;border-bottom-right-radius:10px;border-left:3px solid #cf783f}.blog_sec_first a.post-title h2{font-size:30px!important}.blog_sec_second a.post-title h2{font-size:16px!important;font-weight:700}.sh-404-overay{display:none}.sh-404-title{display:none}.resp-container{position:relative;overflow:hidden;padding-top:56.25%}.resp-iframe{position:absolute;top:0;left:0;width:100%;height:100%;border:0}</style><noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><script data-no-minify="1" async src="https://www.putorius.net/wp-content/cache/busting/1/gtm-7178cb525d7e6d7091f607692801d4fd.js"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-109866879-1');</script> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body class="post-template-default single single-post postid-6036 single-format-standard singular sh-body-header-sticky sh-title-style1 sh-section-tabs-style1 sh-carousel-style1 sh-carousel-position-title sh-post-categories-style1 sh-review-style2 sh-meta-order-bottom sh-instagram-widget-columns2 sh-categories-position-title sh-media-icon-style1 sh-wc-labels-off wpb-js-composer js-comp-ver-6.2.0 vc_responsive"><div class="sh-header-side"><div id="mc4wp_form_widget-2" class="widget-item widget_mc4wp_form_widget"><div class="sh-widget-title-styling"><h3 class="widget-title">Sign Up For Our Newsletter</h3></div><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-2009" method="post" data-id="2009" data-name=""><div class="mc4wp-form-fields"><p> <input type="text" name="NAME" placeholder="Name (Optional)"></p><p> <input type="email" name="EMAIL" placeholder="Email" required=""></p><p> <input type="submit" value="Subscribe"></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1595892598" /><input type="hidden" name="_mc4wp_form_id" value="2009" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></div></div><div class="sh-header-side-overlay"></div><div id="page-container" class=""><div class="sh-page-notice"><div class="container"><div class="sh-table"><div class="sh-table-cell"> <span style="font-size: 13px">If you continue to browse or click Accept, you agree to the storing of cookies on your device. To learn more about why we use cookies, please see our <a href="https://putorius.net/privacy-policy#cookies">cookie policy</a>.</span></div><div class="sh-table-cell text-right"> <a href="#" class="sh-page-notice-button"> Got it! </a></div></div></div></div><header class="primary-mobile"><div id="header-mobile" class="sh-header-mobile"><div class="sh-header-mobile-navigation"><div class="container"><div class="sh-table sh-header-mobile-table"><div class="sh-table-cell"><nav id="header-navigation-mobile" class="header-standard-position sh-header-mobile-navigation-left"><div class="sh-nav-container"><ul class="sh-nav"><li><div class="sh-hamburger-menu sh-nav-dropdown"> <span></span> <span></span> <span></span> <span></span></div></li></ul></div></nav></div><div class="sh-table-cell sh-header-logo-container"><div class="header-logo"> <a href="https://www.putorius.net/" class="header-logo-container sh-table-small"><div class="sh-table-cell"> <img class="sh-standard-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-standard-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript> <img class="sh-sticky-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-sticky-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript> <img class="sh-light-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-light-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript></div> </a></div></div><div class="sh-table-cell"><nav class="header-standard-position sh-header-mobile-navigation-right"><div class="sh-nav-container"><ul class="sh-nav"></ul></div></nav></div></div></div></div><nav class="sh-header-mobile-dropdown"><div class="container sh-nav-container"><ul class="sh-nav-mobile"></ul></div><div class="container sh-nav-container"></div></nav></div></header><header class="primary-desktop"><div class="sh-header-height sh-header-3"><div class="sh-header-middle"><div class="container sh-header-additional"><div class="sh-table"><div class="sh-table-cell sh-header-logo-container"><nav class="header-standard-position"><div class="sh-nav-container"><ul class="sh-nav sh-nav-left"><li><div class="header-logo"> <a href="https://www.putorius.net/" class="header-logo-container sh-table-small"><div class="sh-table-cell"> <img class="sh-standard-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-standard-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript> <img class="sh-sticky-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-sticky-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript> <img class="sh-light-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-light-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript></div> </a></div></li></ul></div></nav></div><div class="sh-table-cell sh-header-banner-container"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display:inline-block;width:875px;height:95px" data-ad-client="ca-pub-8729877671232535" data-ad-slot="5546925678"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></div></div><div class="sh-header sh-header-3 sh-sticky-header"><div class="container"><div class="sh-table"><div class="sh-table-cell sh-header-nav-container"><nav id="header-navigation" class="header-standard-position"><div class="sh-nav-container"><ul id="menu-main" class="sh-nav"><li id="menu-item-130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-130"><a href="https://www.putorius.net" data-ps2id-api="true">Home</a></li><li id="menu-item-389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-389"><a href="https://www.putorius.net/search" data-ps2id-api="true">Search</a></li><li id="menu-item-174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174"><a href="https://www.putorius.net/contact-us" data-ps2id-api="true">Contact</a></li><li id="menu-item-2642" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2642"><a href="https://www.putorius.net/newsletter" data-ps2id-api="true">Newsletter</a></li><li id="menu-item-3180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3180"><a href="https://www.putorius.net/videos" data-ps2id-api="true">Videos</a></li></ul></div></nav></div><div class="sh-table-cell sh-header-meta-container"><nav class="header-standard-position"><div class="sh-nav-container"><ul class="sh-nav"></ul></div></nav></div></div></div><div class="sh-header-search-side"><div class="sh-header-search-side-container"><form method="get" class="sh-header-search-form" action="https://www.putorius.net/"> <input type="text" value="" name="s" class="sh-header-search-side-input" placeholder="Enter a keyword to search..." /><div class="sh-header-search-side-close"> <i class="ti-close"></i></div><div class="sh-header-search-side-icon"> <i class="ti-search"></i></div></form></div></div></div></div></header><div class="blog-slider blog-slider-style3 6036" style="position: relative;"><div class="blog-slider-list slick-initialized"><div data-bg="https://www.putorius.net/wp-content/uploads/2020/02/Putorius-Feature-Default.jpg" class="blog-slider-item rocket-lazyload" style=""><div class="blog-slider-container"><div class="blog-slider-content"><div class="blog-slider-content-icon"> <i class="icon icon-pencil"></i></div><div class="blog-slider-content-details"><div class="post-categories-container"><div class="post-categories"><a href="https://www.putorius.net/category/linux-tutorials">Linux Tutorials</a>, <a href="https://www.putorius.net/category/security">Security</a></div></div><h1 class="post-title"> Create iptables Rules Based on Hostname Using IP Sets</h1><div class="post-meta"><div class="post-meta-content"> <span class="post-auhor-date post-auhor-date-full"> <a href="https://www.putorius.net/author/mcherisi"> </a> <span> <a href="https://www.putorius.net/author/mcherisi" class="post-author">Marco Cherisi</a></span>, <a href="https://www.putorius.net/ipset-iptables-rules-for-hostname.html" class="post-date"> July 27, 2020 </a> </span> <a href="https://www.putorius.net/ipset-iptables-rules-for-hostname.html#comments" class="post-comments"> <i class="icon icon-bubble"></i> 0 </a> <span class="post-readtime"> <i class="icon icon-clock"></i> 5 min <span>read</span> </span> <span class="placeholder-post-read-later"></span></div></div></div></div></div></div></div><div class="blog-slider-dots"></div></div><div id="wrapper" class="layout-default"><div class="content-container sh-page-layout-default"><div class="container entry-content"><div id="content-wrapper" class="content-wrapper-with-sidebar"><div id="content" class="content-layout-sidebar-right content-with-sidebar-right"><div class="blog-single blog-style-single blog-blockquote-style1 blog-style-post-slider"><article id="post-6036" class="post-item post-item-single post-6036 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-tutorials category-security tag-firewall tag-iptables"><meta content="https://www.putorius.net/wp-content/uploads/2020/02/Putorius-Feature-Default-1024x597.jpg" itemprop="image" /><div class="post-item-single-container"><div class="post-content post-single-content"><p>IPTables is a very powerful tool for creating a firewall on your Linux system. However, all the rules are based on IP addresses. For example, you can <a href="https://www.putorius.net/basic-of-iptables-opening-ports-on.html" target="_blank" aria-label="undefined (opens in a new tab)" rel="noreferrer noopener">open a port </a>to a specific source IP address.</p><p>What if you have a client that needs to connect to a service that does not have a static IP address? The client would need to monitor changes to their IP address, send you the new IP, and you would then have to manually update your iptables rules to allow them access. There has to be a better way.</p><p>This was my thought when I had a customer that needed <a href="https://www.putorius.net/?s=ssh">SSH</a> access to his server from his home. He has a cable internet connection that changes his <a href="https://www.putorius.net/find-public-ip-address-linux-command-line.html" target="_blank" aria-label="undefined (opens in a new tab)" rel="noreferrer noopener">pubic IP address</a> at least once a month (sometimes once a week). I could just open SSH to the world and allow him to connect, but that is not very secure. The solution we worked out is to use Dynamic DNS to tie his IP address to a hostname, then use IP Sets and a simple Bash script to automatically update <a href="https://www.putorius.net/?s=iptables" target="_blank" aria-label="undefined (opens in a new tab)" rel="noreferrer noopener">iptables</a>.</p><p>NOTE: Configuring the client of Dyamic DNS is outside the scope of this tutorial. There are several methods to accomplish this. Let us know in the comments if you need help.</p><h2>Configuring IP Sets with iptables</h2><p>IP Sets is a framework that allows you to create "sets" of IP addresses, MAC address, networks, port numbers and more. These sets can then be used inside of iptables rules. This may seem complicated, however, it is very simple. With just a few commands you can configure an IP Set. Then we will create a simple bash script to update the set.</p><p>For this example, let's assume the client has the following dynamic DNS name setup:<br>client1.example.com</p><h3>Creating Your IP Set</h3><p>The first step is to create your IP Set to hold the IP address of your client.</p><pre class="wp-block-code"><code>&#91;mcherisi@putor ~]$ sudo ipset create ssh-allowed hash:ip</code></pre><p>Here we are telling the ipset utility to create a set called "ssh-allowed" with the type of "hash:ip". This will be used to store the IP addresses of systems allowed to SSH into our server.</p><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="PHNjcmlwdCBhc3luYyBzcmM9Imh0dHBzOi8vcGFnZWFkMi5nb29nbGVzeW5kaWNhdGlvbi5jb20vcGFnZWFkL2pzL2Fkc2J5Z29vZ2xlLmpzIj48L3NjcmlwdD4KPGlucyBjbGFzcz0iYWRzYnlnb29nbGUiCiAgICAgc3R5bGU9ImRpc3BsYXk6YmxvY2s7IHRleHQtYWxpZ246Y2VudGVyOyIKICAgICBkYXRhLWFkLWxheW91dD0iaW4tYXJ0aWNsZSIKICAgICBkYXRhLWFkLWZvcm1hdD0iZmx1aWQiCiAgICAgZGF0YS1hZC1jbGllbnQ9ImNhLXB1Yi04NzI5ODc3NjcxMjMyNTM1IgogICAgIGRhdGEtYWQtc2xvdD0iNDk3MzM3Nzg5MSI+PC9pbnM+CjxzY3JpcHQ+CiAgICAgKGFkc2J5Z29vZ2xlID0gd2luZG93LmFkc2J5Z29vZ2xlIHx8IFtdKS5wdXNoKHt9KTsKPC9zY3JpcHQ+" data-class="Y29kZS1ibG9jaw=="></div></div><p>We can now view this IP Set and see that is has no members. This is expected since we have not yet added any IP addresses. In the next steps we will configure iptables to use this IP Set. Then create a Bash script to add our clients IP address based of their Dynamic DNS name.</p><pre class="wp-block-code"><code>&#91;mcherisi@putor ~]$ sudo ipset list ssh-allowed
Name: ssh-allowed
Type: hash:ip
Revision: 4
Header: family inet hashsize 1024 maxelem 65536
Size in memory: 200
References: 0
Number of entries: 0
Members:</code></pre><p>You can manually add IP addresses to the set for testing.</p><pre class="wp-block-code"><code>&#91;mcherisi@putor ~]$ sudo ipset add ssh-allowed 192.168.100.197</code></pre><p>Now if we list the "ssh-allowed" IP Set, we will see we have one member.</p><pre class="wp-block-code"><code>&#91;mcherisi@putor ~]$ sudo ipset list ssh-allowed
Name: ssh-allowed
Type: hash:ip
Revision: 4
Header: family inet hashsize 1024 maxelem 65536
Size in memory: 248
References: 1
Number of entries: 1
Members:
192.168.100.197</code></pre><h3>Using the IP Set to Create an iptables Rule</h3><p>Now that we have our IP Set created, let's create a rule in iptables that tells it to allow SSH traffic from addresses inside this IP Set.</p><pre class="wp-block-code"><code>sudo iptables -I INPUT -p tcp --dport 22 -m set --match-set ssh-allowed src -j ACCEPT</code></pre><p>Now iptables is configured to check the "ssh-allowed" IP set for source IP addresses for incoming SSH connections.</p><pre class="wp-block-code"><code>&#91;mcherisi@putor ~]$ sudo iptables -L -vn
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            tcp dpt:22 match-set ssh-allowed src
...OUTPUT TRUNCATED...</code></pre><p>Any IP address that is a member of the "ssh-allowed" IP Set is now permitted to connect to SSH on destination port 22.</p><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="PHNjcmlwdCBhc3luYyBzcmM9Imh0dHBzOi8vcGFnZWFkMi5nb29nbGVzeW5kaWNhdGlvbi5jb20vcGFnZWFkL2pzL2Fkc2J5Z29vZ2xlLmpzIj48L3NjcmlwdD4KPGlucyBjbGFzcz0iYWRzYnlnb29nbGUiCiAgICAgc3R5bGU9ImRpc3BsYXk6YmxvY2s7IHRleHQtYWxpZ246Y2VudGVyOyIKICAgICBkYXRhLWFkLWxheW91dD0iaW4tYXJ0aWNsZSIKICAgICBkYXRhLWFkLWZvcm1hdD0iZmx1aWQiCiAgICAgZGF0YS1hZC1jbGllbnQ9ImNhLXB1Yi04NzI5ODc3NjcxMjMyNTM1IgogICAgIGRhdGEtYWQtc2xvdD0iNDk3MzM3Nzg5MSI+PC9pbnM+CjxzY3JpcHQ+CiAgICAgKGFkc2J5Z29vZ2xlID0gd2luZG93LmFkc2J5Z29vZ2xlIHx8IFtdKS5wdXNoKHt9KTsKPC9zY3JpcHQ+" data-class="Y29kZS1ibG9jaw=="></div></div><h3>Creating a Bash Script to Automatically Update IP Tables by Hostname</h3><p>Our client has Dynamic DNS configured to update the hostname <code>client1.example.com</code> with their IP address automatically. All that remains is to set up a script to update our "ssh-allow" IP set with the IP address of that hostname.</p><p>NOTE: You must have the <a href="https://www.putorius.net/dig-command-usage-and-examples.html" target="_blank" aria-label="undefined (opens in a new tab)" rel="noreferrer noopener">dig utility</a> installed.</p><p>The script below will use the dig utility to find the IP address of <code>client1.example.com</code> and set the <code>ip</code> variable with it. It will then flush the IP Set to remove any old IP addresses, then insert the new IP address allowing it access to the server via SSH.</p><pre class="wp-block-code"><code>#!/bin/bash
# Find IP address and store it in $ip
ip=`dig +short client1.example.com`

# Flush old IP addresses from ssh-allowed IP Set
ipset flush ssh-allowed

# Add new IP address to ssh-allowed IP Set
ipset add ssh-allowed $ip</code></pre><p>We can place this script in /etc/cron.daily to run every day, or create a basic cron job to run it as often as we like. As the client automatically updates Dynamic DNS, this script will ensure they still have access to the server.</p><h2>Conclusion</h2><p>Using IP sets allows you to create an easy to manage list of IP addresses that iptables can use in it's rules. As we have shown when paired with a simple Bash script it can also help to create rules from a hostname or domain name.</p><p>There is a full tutorial in the works for ipset. <a href="https://www.putorius.net/newsletter" target="_blank" aria-label="undefined (opens in a new tab)" rel="noreferrer noopener">Sign up for our newsletter</a> to keep up with all our new releases.</p><h2>Resources and Links</h2><ul><li><a aria-label="undefined (opens in a new tab)" href="https://ipset.netfilter.org/index.html" target="_blank" rel="noreferrer noopener">IP Set home page</a> at netfilter.org</li><li><a href="https://www.putorius.net/basic-of-iptables-opening-ports-on.html" target="_blank" aria-label="undefined (opens in a new tab)" rel="noreferrer noopener">The Basics of IPTables</a></li></ul></div><div class="sh-page-links"></div><div class="post-tags-container"><div class="post-tags"> <a class="post-tags-item post-tags-item-title"> Tags </a> <a href="https://www.putorius.net/tag/firewall" class="post-tags-item"> #firewall </a> <a href="https://www.putorius.net/tag/iptables" class="post-tags-item"> #iptables </a></div><div class="sh-clear"></div></div></div><div class="post-switch post-swtich-style2"><div class="row"><div class="col-md-6"> <span class="post-switch-next text-left"><div class="post-switch-type">Previous</div><h4> Create iptables Rules Based on Hostname Using IP Sets</h4> </span></div><div class="col-md-6"> <a href="https://www.putorius.net/shred-command-securely-delete-files.html" class="post-switch-next text-right"><div class="post-switch-type">Next</div><h4> Shred Command - Securely Delete Files in Linux</h4> </a></div></div></div></article><div class="sh-comment-form"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ipset-iptables-rules-for-hostname.html#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.putorius.net/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><label>Your comment <span>*</span></label><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" required></textarea></p><div class="sh-comment-form-column"><label>Name <span>*</span></label><p class="comment-form-author"> <input id="author" name="author" type="text" value="" required /></p></div><div class="sh-comment-form-column"><label>Email <span>*</span></label><p class="comment-form-email"> <input id="email" name="email" type="text" value="" required /></p></div><div class="sh-comments-required-notice">Required fields are marked <span>*</span></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Send a comment" /> <input type='hidden' name='comment_post_ID' value='6036' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="6d474f37d0" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="84" /></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div><div class="sh-comments"></div></div></div><div id="sidebar" class="sidebar-right"><div class="sidebar-container"><div id="custom_html-5" class="widget_text widget-item widget_custom_html"><div class="textwidget custom-html-widget"><ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-8729877671232535" data-ad-slot="9553892499"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><div id="mc4wp_form_widget-3" class="widget-item widget_mc4wp_form_widget"><div class="sh-widget-title-styling"><h3 class="widget-title">Join Our Newsletter</h3></div><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-2009" method="post" data-id="2009" data-name=""><div class="mc4wp-form-fields"><p> <input type="text" name="NAME" placeholder="Name (Optional)"></p><p> <input type="email" name="EMAIL" placeholder="Email" required=""></p><p> <input type="submit" value="Subscribe"></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1595892598" /><input type="hidden" name="_mc4wp_form_id" value="2009" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2" /><div class="mc4wp-response"></div></form></div><div id="categories-3" class="widget-item widget_categories"><div class="sh-widget-title-styling"><h3 class="widget-title">Categories</h3></div><ul><li class="cat-item cat-item-516"><a href="https://www.putorius.net/category/bash-scripting">Bash Scripting</a> (16)</li><li class="cat-item cat-item-517"><a href="https://www.putorius.net/category/basic-commands">Basic Commands</a> (44)</li><li class="cat-item cat-item-7177"><a href="https://www.putorius.net/category/featured">Featured</a> (7)</li><li class="cat-item cat-item-510"><a href="https://www.putorius.net/category/just-for-fun">Just for Fun</a> (4)</li><li class="cat-item cat-item-508"><a href="https://www.putorius.net/category/linux-quick-tips">Linux Quick Tips</a> (78)</li><li class="cat-item cat-item-504"><a href="https://www.putorius.net/category/linux-tutorials">Linux Tutorials</a> (56)</li><li class="cat-item cat-item-507"><a href="https://www.putorius.net/category/misc-tech">Miscellaneous</a> (11)</li><li class="cat-item cat-item-7333"><a href="https://www.putorius.net/category/network-tools">Network Tools</a> (6)</li><li class="cat-item cat-item-8651"><a href="https://www.putorius.net/category/reviews">Reviews</a> (2)</li><li class="cat-item cat-item-506"><a href="https://www.putorius.net/category/security">Security</a> (26)</li></ul></div></div></div></div></div></div><footer class="sh-footer"><div class="sh-copyrights sh-copyrights-align-left"><div class="container container-padding"><div class="sh-table"><div class="sh-table-cell"><div class="sh-copyrights-info"> <span>© 2010-2020 Putorius - All Rights Reserved</span></div></div><div class="sh-table-cell"><div class="sh-nav-container"><ul id="menu-footer-menu" class="sh-nav"><li id="menu-item-5869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5869"><a href="https://www.putorius.net" data-ps2id-api="true">HOME</a></li><li id="menu-item-531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-531"><a href="https://www.putorius.net/privacy-policy" data-ps2id-api="true">Privacy Policy</a></li><li id="menu-item-2769" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2769"><a href="https://www.putorius.net/about-putorius" data-ps2id-api="true">About</a></li><li id="menu-item-282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-282"><a href="https://www.putorius.net/contact-us" data-ps2id-api="true">CONTACT</a></li><li id="menu-item-407" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-407"><a href="https://www.putorius.net/search" data-ps2id-api="true">SEARCH</a></li><li id="menu-item-2068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2068"><a href="https://www.putorius.net/newsletter" data-ps2id-api="true">Newsletter</a></li><li id="menu-item-3181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3181"><a href="https://www.putorius.net/videos" data-ps2id-api="true">Videos</a></li></ul></div></div></div></div></div></footer></div><div id="login-register" style="display: none;"><div class="sh-login-popup-tabs"><ul class="nav nav-tabs"><li class="active"> <a data-target="#viens" data-toggle="tab">Login</a></li><li> <a data-target="#divi" data-toggle="tab">Register</a></li></ul></div><div class="tab-content"><div class="tab-pane active" id="viens"><div class="sh-login-popup-content sh-login-popup-content-login"><form name="loginform" id="loginform" action="https://www.putorius.net/wp-login.php" method="post"><p class="login-username"> <label for="user_login">Username or Email Address</label> <input type="text" name="log" id="user_login" class="input" value="" size="20" /></p><p class="login-password"> <label for="user_pass">Password</label> <input type="password" name="pwd" id="user_pass" class="input" value="" size="20" /></p> <a href="/wp-login.php?action=lostpassword" class="login-forgot-password">Forgot Password</a><p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p><p class="login-submit"> <input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" /> <input type="hidden" name="redirect_to" value="https://www.putorius.net/ipset-iptables-rules-for-hostname.html" /></p></form></div></div><div class="tab-pane" id="divi"><div class="sh-login-popup-content"><p id="reg_passmail">Registration is closed.</p></div></div></div></div></div> <style type="text/css">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</style><script type='text/javascript'>/* <![CDATA[ */ var wpcf7 = {"apiSettings":{"root":"https:\/\/www.putorius.net\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var mPS2id_params = {"instances":{"mPS2id_instance_0":{"selector":"a[href*='#']:not([href='#'])","autoSelectorMenuLinks":"true","excludeSelector":"a[href^='#tab-'], a[href^='#tabs-'], a[data-toggle]:not([data-toggle='tooltip']), a[data-slide], a[data-vc-tabs], a[data-vc-accordion]","scrollSpeed":800,"autoScrollSpeed":"true","scrollEasing":"easeInOutQuint","scrollingEasing":"easeOutQuint","pageEndSmoothScroll":"true","stopScrollOnUserAction":"false","autoCorrectScroll":"false","layout":"vertical","offset":"110","dummyOffset":"false","highlightSelector":"","clickedClass":"mPS2id-clicked","targetClass":"mPS2id-target","highlightClass":"mPS2id-highlight","forceSingleHighlight":"false","keepHighlightUntilNext":"false","highlightByNextTarget":"false","appendHash":"false","scrollToHash":"true","scrollToHashForAll":"true","scrollToHashDelay":0,"scrollToHashUseElementData":"true","scrollToHashRemoveUrlHash":"false","disablePluginBelow":0,"adminDisplayWidgetsId":"true","adminTinyMCEbuttons":"true","unbindUnrelatedClickEvents":"false","normalizeAnchorPointTargets":"false"}},"total_instances":"1","shortcode_class":"_ps2id"}; /* ]]> */</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.putorius.net/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>const wprRemoveCPCSS = () => { $elem = document.getElementById( "rocket-critical-css" ); if ( $elem ) { $elem.remove(); } }; if ( window.addEventListener ) { window.addEventListener( "load", wprRemoveCPCSS ); } else if ( window.attachEvent ) { window.attachEvent( "onload", wprRemoveCPCSS ); }</script><script src="https://www.putorius.net/wp-content/cache/min/1/598ead32a0734b14ea4c6a299f74bb34.js" data-minify="1" defer></script><script type="text/javascript" id="slb_context">/* <![CDATA[ */ if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);} /* ]]> */</script><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%2C400italic%2C700italic%7CMontserrat%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2Cregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&#038;subset=latin&#038;display=swap" /><link rel="stylesheet" href="https://www.putorius.net/wp-content/cache/min/1/097049bb687b40e9bec29b3a0e481e88.css" data-minify="1" /></noscript></body></html>
