<!DOCTYPE html>
<html lang="en-US">
<head><meta charset="UTF-8"><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Automatically Install Updates on RHEL8 or Fedora - Putorius</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%2C400italic%2C700italic%7CMontserrat%3A300%2C400%2C400i%2C700%7COpen%20Sans%3A300%2C400%2C400i%2C700%7CMontserrat&#038;subset=latin&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%2C400italic%2C700italic%7CMontserrat%3A300%2C400%2C400i%2C700%7COpen%20Sans%3A300%2C400%2C400i%2C700%7CMontserrat&#038;subset=latin&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%2C400italic%2C700italic%7CMontserrat%3A300%2C400%2C400i%2C700%7COpen%20Sans%3A300%2C400%2C400i%2C700%7CMontserrat&#038;subset=latin&#038;display=swap" /></noscript>
<meta name="description" content="Learn how to configure your systems to automatically install updates using dnf. Works on Red Hat, CentOS, and Fedora." />
<link rel="canonical" href="https://www.putorius.net/automatically-install-updates-on-rhel8-or-fedora.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Automatically Install Updates on RHEL8 or Fedora" />
<meta property="og:description" content="Learn how to configure your systems to automatically install updates using dnf. Works on Red Hat, CentOS, and Fedora." />
<meta property="og:url" content="https://www.putorius.net/automatically-install-updates-on-rhel8-or-fedora.html" />
<meta property="og:site_name" content="Putorius" />
<meta property="article:publisher" content="https://www.facebook.com/putorius.net" />
<meta property="article:published_time" content="2022-04-25T00:12:10+00:00" />
<meta property="article:modified_time" content="2022-04-25T12:52:00+00:00" />
<meta property="og:image" content="https://www.putorius.net/wp-content/uploads/2020/02/Putorius-Feature-Default.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="700" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@CuriousPutorius" />
<meta name="twitter:site" content="@CuriousPutorius" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Steven Vona" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="3 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link rel='dns-prefetch' href='//youtube.com' />
<link rel='dns-prefetch' href='//jnn-pa.googleapis.com' />
<link rel='dns-prefetch' href='//gstatic.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Putorius &raquo; Feed" href="https://www.putorius.net/feed" />
<link rel="alternate" type="application/rss+xml" title="Putorius &raquo; Comments Feed" href="https://www.putorius.net/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Putorius &raquo; Automatically Install Updates on RHEL8 or Fedora Comments Feed" href="https://www.putorius.net/automatically-install-updates-on-rhel8-or-fedora.html/feed" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.putorius.net/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<style id='extendify-gutenberg-patterns-and-templates-utilities-inline-css' type='text/css'>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</style>
<link data-minify="1" rel='stylesheet' id='widget-builder-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/plugins/ultimate-widget-builder-pro-vc/assets/css/home-widget-builder.css?ver=1650242201' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='slb_core-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/plugins/simple-lightbox/client/css/app.css?ver=1650242201' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='bootstrap-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/themes/gillion/css/plugins/bootstrap.min.css?ver=1650242201' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='font-awesome-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/themes/gillion/css/plugins/font-awesome.min.css?ver=1650242201' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='gillion-plugins-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/themes/gillion/css/plugins.css?ver=1650242201' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='gillion-styles-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/themes/gillion/style.css?ver=1650242203' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='gillion-responsive-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/themes/gillion/css/responsive.css?ver=1650242203' type='text/css' media='all' />
<style id='gillion-responsive-inline-css' type='text/css'>
@media (min-width: 1250px) {.container { max-width: 1200px!important;min-width: 1200px!important; width: 1200px!important;}/* Elementor Page Builder */.elementor-section-boxed.elementor-top-section > .elementor-container { width: 1200px;min-width: auto;max-width: 100%; }.elementor-section-boxed.elementor-top-section > .elementor-container .elementor-section > .elementor-container {width: 100%;}} 



</style>
<link data-minify="1" rel='stylesheet' id='gillion-theme-settings-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/uploads/gillion-dynamic-styles.css?ver=1650242203' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='plyr-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/themes/gillion/css/plugins/plyr.css?ver=1650242203' type='text/css' media='all' />
<link rel='stylesheet' id='gillion-child-style-css' href='https://www.putorius.net/wp-content/themes/gillion-child/style.css?ver=5.9.3' type='text/css' media='all' />
<noscript></noscript><link data-minify="1" rel='stylesheet' id='wyp-custom-css' href='https://www.putorius.net/wp-content/cache/min/1/wp-content/uploads/yellow-pencil/custom-208.css?ver=1650242203' type='text/css' media='all' />
<script type='text/javascript' src='https://www.putorius.net/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js' defer></script>
<script type='text/javascript' src='https://www.putorius.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>

<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-109866879-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.putorius.net"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-109866879-1", {"anonymize_ip":true});
gtag("config", "G-XKHN0PCQ34");
</script>

<script data-minify="1" type='text/javascript' src='https://www.putorius.net/wp-content/cache/min/1/wp-content/themes/gillion/js/plugins.js?ver=1650242203' id='gillion-plugins-js' defer></script>
<script type='text/javascript' id='gillion-scripts-js-extra'>
/* <![CDATA[ */
var gillion_loadmore_posts = {"ajax_url":"https:\/\/www.putorius.net\/wp-admin\/admin-ajax.php"};
var gillion = {"siteurl":"https:\/\/www.putorius.net\/","loggedin":"","page_loader":"0","notice":"","header_animation_dropdown_delay":"0","header_animation_dropdown":"easeOutQuint","header_animation_dropdown_speed":"0","lightbox_opacity":"0.88","lightbox_transition":"elastic","page_numbers_prev":"Previous","page_numbers_next":"Next","rtl_support":"","footer_parallax":"","social_share":"[]","text_show_all":"Show All","single_post_slider_parallax":"1"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.putorius.net/wp-content/cache/min/1/wp-content/themes/gillion/js/scripts.js?ver=1650242203' id='gillion-scripts-js' defer></script>
<script type='text/javascript' src='https://www.putorius.net/wp-content/themes/gillion/js/plugins/plyr.min.js?ver=5.9.3' id='plyr-js' defer></script>
<script data-minify="1" type='text/javascript' src='https://www.putorius.net/wp-content/cache/min/1/wp-content/themes/gillion-child/js/scripts.js?ver=1650242203' id='gillion-child-scripts-js' defer></script>
<link rel="https://api.w.org/" href="https://www.putorius.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.putorius.net/wp-json/wp/v2/posts/6742" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.putorius.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.putorius.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9.3" />
<link rel='shortlink' href='https://www.putorius.net/?p=6742' />
<link rel="alternate" type="application/json+oembed" href="https://www.putorius.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.putorius.net%2Fautomatically-install-updates-on-rhel8-or-fedora.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.putorius.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.putorius.net%2Fautomatically-install-updates-on-rhel8-or-fedora.html&#038;format=xml" />
<meta name="generator" content="Redux 4.3.12" /><meta name="generator" content="Site Kit by Google 1.72.0" />

<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">

<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<link rel="amphtml" href="https://www.putorius.net/automatically-install-updates-on-rhel8-or-fedora.html/amp">

<script type="rocketlazyloadscript" async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-8729877671232535" crossorigin="anonymous" data-rocket-type="text/javascript"></script>

<style type="text/css">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</style><link rel="icon" href="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-80x80.png.webp" sizes="32x32" />
<link rel="icon" href="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-220x220.png.webp" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-220x220.png.webp" />
<meta name="msapplication-TileImage" content="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-300x300.png" />
<style type="text/css" id="wp-custom-css">
			/* Add little weasel in bottom right bg */

body {
background: url(https://www.putorius.net/wp-content/uploads/2020/01/tesoro-putorius.jpg.webp) bottom right no-repeat fixed;
}

/* Allow sidebar to scroll with page */
#sidebar .theiaStickySidebar {
    position: static !important;
    transform: none !important;
}

/* Reduce header height - top margin */
.container.sh-header-additional {
    padding: 1 !important;
}
.sh-header-banner-container br {
    display: none;
}


/* Reduce title font on mobile */
body #page-container a.post-title h2 {
    font-size: 22px;
}

.sh-header-mobile-dropdown {
        top: -21px;
}

/* Change pre tag to highlight code */
pre { 
background: rgba(232,232,232,1);
color: rgba(0,0,0,1);
border-top-left-radius: 0px;
border-bottom-left-radius: 0px;
border-top-right-radius: 10px;
border-bottom-right-radius: 10px;
border-left: 3px solid #cf783f;
 }

.blog_sec_first a.post-title h2 {
    font-size: 30px !important;
}
.blog_sec_second a.post-title h2 {
    font-size: 16px !important;
    font-weight: 700;
}
/* Clean up 404 page */
.sh-404-overay {
		display:none;
}
.sh-404-title {
	display:none;
}

.resp-container {
    position: relative;
    overflow: hidden;
    padding-top: 56.25%;
}

.resp-iframe {
    position: absolute;
    top: 0;
    left: 0;
    width: 100%;
    height: 100%;
    border: 0;
}


		</style>
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-6742 single-format-standard non-logged-in singular sh-body-header-sticky sh-title-style1 sh-section-tabs-style1 sh-carousel-style1 sh-carousel-position-title sh-post-categories-style1 sh-review-style2 sh-meta-order-bottom sh-instagram-widget-columns2 sh-categories-position-title sh-media-icon-style1 sh-wc-labels-off wpb-js-composer js-comp-ver-6.9.0 vc_responsive">
<div class="sh-header-side">
<div id="mc4wp_form_widget-2" class="widget-item widget_mc4wp_form_widget"><div class="sh-widget-title-styling"><h5 class="widget-title">Sign Up For Our Newsletter</h5></div><script type="rocketlazyloadscript">(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-2009" method="post" data-id="2009" data-name=""><div class="mc4wp-form-fields"><p>
<input type="text" name="NAME" placeholder="Name (Optional)">
</p>
<p>
<input type="email" name="EMAIL" placeholder="Email" required="">
</p>
<p>
<input type="submit" value="Subscribe">
</p>
</div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1650891121" /><input type="hidden" name="_mc4wp_form_id" value="2009" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></div> </div>
<div class="sh-header-side-overlay"></div>
<div id="page-container" class="">
<header class="primary-mobile">
<div id="header-mobile" class="sh-header-mobile">
<div class="sh-header-mobile-navigation">
<div class="container">
<div class="sh-table sh-header-mobile-table">
<div class="sh-table-cell">
<nav id="header-navigation-mobile" class="header-standard-position sh-header-mobile-navigation-left">
<div class="sh-nav-container">
<ul class="sh-nav">
<li>
<div class="sh-hamburger-menu sh-nav-dropdown">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</li>
</ul>
</div>
</nav>
</div>
<div class="sh-table-cell sh-header-logo-container">
<div class="header-logo">
<a href="https://www.putorius.net/" class="header-logo-container sh-table-small">
<div class="sh-table-cell">
<img width="275" height="55" class="sh-standard-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20275%2055'%3E%3C/svg%3E" alt="Putorius" height=&quot;50&quot; data-lazy-src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" /><noscript><img width="275" height="55" class="sh-standard-logo" src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" alt="Putorius" height=&quot;50&quot; /></noscript>
<img width="275" height="55" class="sh-sticky-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20275%2055'%3E%3C/svg%3E" alt="Putorius" height=&quot;50&quot; data-lazy-src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" /><noscript><img width="275" height="55" class="sh-sticky-logo" src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" alt="Putorius" height=&quot;50&quot; /></noscript>
<img width="275" height="55" class="sh-light-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20275%2055'%3E%3C/svg%3E" alt="Putorius" height=&quot;50&quot; data-lazy-src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" /><noscript><img width="275" height="55" class="sh-light-logo" src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" alt="Putorius" height=&quot;50&quot; /></noscript>
</div>
</a>
</div>
</div>
<div class="sh-table-cell">
<nav class="header-standard-position sh-header-mobile-navigation-right">
<div class="sh-nav-container">
<ul class="sh-nav">
</ul>
</div>
</nav>
</div>
</div>
</div>
</div>
<nav class="sh-header-mobile-dropdown">
<div class="container sh-nav-container">
<ul class="sh-nav-mobile"></ul>
</div>
<div class="container sh-nav-container">
</div>
</nav>
</div>
</header>
<header class="primary-desktop">
<div class="sh-header-height sh-header-3">
<div class="sh-header-middle">
<div class="container sh-header-additional">
<div class="sh-table">
<div class="sh-table-cell sh-header-logo-container">
<nav class="header-standard-position">
<div class="sh-nav-container">
<ul class="sh-nav sh-nav-left">
<li>
<div class="header-logo">
<a href="https://www.putorius.net/" class="header-logo-container sh-table-small">
<div class="sh-table-cell">
<img width="275" height="55" class="sh-standard-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20275%2055'%3E%3C/svg%3E" alt="Putorius" height=&quot;50&quot; data-lazy-src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" /><noscript><img width="275" height="55" class="sh-standard-logo" src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" alt="Putorius" height=&quot;50&quot; /></noscript>
<img width="275" height="55" class="sh-sticky-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20275%2055'%3E%3C/svg%3E" alt="Putorius" height=&quot;50&quot; data-lazy-src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" /><noscript><img width="275" height="55" class="sh-sticky-logo" src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" alt="Putorius" height=&quot;50&quot; /></noscript>
<img width="275" height="55" class="sh-light-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20275%2055'%3E%3C/svg%3E" alt="Putorius" height=&quot;50&quot; data-lazy-src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" /><noscript><img width="275" height="55" class="sh-light-logo" src="https://www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png.webp" alt="Putorius" height=&quot;50&quot; /></noscript>
</div>
</a>
</div>
</li>
</ul>
</div>
</nav>
</div>
<div class="sh-table-cell sh-header-banner-container">
<p><script type="rocketlazyloadscript" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:inline-block;width:875px;height:95px" data-ad-client="ca-pub-8729877671232535" data-ad-slot="5546925678"></ins><br />
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</div>
</div>
</div>
<div class="sh-header sh-header-3 sh-sticky-header">
 <div class="container">
<div class="sh-table">
<div class="sh-table-cell sh-header-nav-container">
<nav id="header-navigation" class="header-standard-position">
<div class="sh-nav-container"><ul id="menu-main" class="sh-nav"><li id="menu-item-130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-130"><a href="https://www.putorius.net" data-ps2id-api="true">Home</a></li><li id="menu-item-389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-389"><a href="https://www.putorius.net/search" data-ps2id-api="true">Search</a></li><li id="menu-item-174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174"><a href="https://www.putorius.net/contact-us" data-ps2id-api="true">Contact</a></li><li id="menu-item-2642" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2642"><a href="https://www.putorius.net/newsletter" data-ps2id-api="true">Newsletter</a></li><li id="menu-item-3180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3180"><a href="https://www.putorius.net/videos" data-ps2id-api="true">Videos</a></li></ul></div> </nav>
</div>
<div class="sh-table-cell sh-header-meta-container">
<nav class="header-standard-position">
<div class="sh-nav-container">
<ul class="sh-nav">
</ul>
</div>
</nav>
</div>
</div>
</div>
<div class="sh-header-search-side">
<div class="sh-header-search-side-container">
<form method="get" class="sh-header-search-form" action="https://www.putorius.net/">
<input type="text" value="" name="s" class="sh-header-search-side-input" placeholder="Enter a keyword to search..." />
<div class="sh-header-search-side-close">
<i class="ti-close"></i>
</div>
<div class="sh-header-search-side-icon">
<i class="ti-search"></i>
</div>
</form>
</div>
</div>
</div>
</div>
</header>
<div id="wrapper" class="layout-default">
<div class="content-container sh-page-layout-default">
<div class="container entry-content">
<div id="content-wrapper" class="content-wrapper-with-sidebar">
<div id="content" class="content-layout-sidebar-right content-with-sidebar-right">
<div class="blog-single blog-style-single blog-blockquote-style1  blog-style-post-toptitle">
<article id="post-6742" class="post-item post-item-single post-6742 post type-post status-publish format-standard has-post-thumbnail hentry category-security tag-dnf tag-dnf-automatic tag-security-updates tag-updates">
<meta content="https://www.putorius.net/wp-content/uploads/2022/04/automatic-updates-dnf-1024x614.jpg" itemprop="image" />
<div class="post-item-single-container">
<div class="post-single-meta">
<div class="post-categories-container">
<div class="post-categories"><a href="https://www.putorius.net/category/security">Security</a></div>
</div>
<a class="post-title">
<h1>
Automatically Install Updates on RHEL8 or Fedora </h1>
</a>
<div class="post-meta">
<div class="post-meta-content">
<span class="post-auhor-date post-auhor-date-full">
<a href="https://www.putorius.net/author/savona">
</a>
<span>
<a href="https://www.putorius.net/author/savona" class="post-author">Steven Vona</a></span>,
<a href="https://www.putorius.net/automatically-install-updates-on-rhel8-or-fedora.html" class="post-date">
April 24, 2022 </a>
 </span>
<span class="placeholder-post-read-later"></span>
</div>
</div>
</div>
<div class="post-type-content">
<div class="post-thumbnail">
<img width="1200" height="675" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20675'%3E%3C/svg%3E" alt="Automatically Install Updates on RHEL8 or Fedora" data-lazy-src="https://www.putorius.net/wp-content/uploads/2022/04/automatic-updates-dnf-1200x675.jpg.webp"><noscript><img width="1200" height="675" src="https://www.putorius.net/wp-content/uploads/2022/04/automatic-updates-dnf-1200x675.jpg.webp" alt="Automatically Install Updates on RHEL8 or Fedora"></noscript>
<a href="https://www.putorius.net/wp-content/uploads/2022/04/automatic-updates-dnf-scaled.jpg.webp" class="post-lightbox" data-rel="lightcase:post_gallery_6742"></a>
</div>
</div>
<div class="post-content post-single-content">
<p>Long time Server admins usually aren't fans of automatically installing updates on production systems. However, it may be a good idea on workstations or on closely monitored servers. It can save you some time, keep the system vulnerabilities down, and kill bugs fast. In this Linux quick tip we will discuss configuring your system to automatically install updates using DNF package manager.</p>
<p> The DNF package manager provides a timer unit that will do this for you. All you need to do is install, configure, and enable it. If you are unsure of what a timer unit is, read "<a href="https://www.putorius.net/using-systemd-timers.html">Using systemd timer units to schedule jobs</a>". Let's install, configure, and enable the dnf-automatic.timer unit to install updates automatically.</p>
<h2 id="h-install-and-configure-the-dnf-automatic-package">Install and Configure the dnf-automatic Package</h2>
<p>Let's use DNF to install the package. </p>
<pre class="wp-block-code"><code>&#91;<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="384b594e57565978484d4c574a">[email&#160;protected]</a> ~]$ sudo dnf install dnf-automatic</code></pre>
<p>Now that we have the package installed, let's edit the main configuration file. The file is located at <code>/etc/dnf/automatic.conf</code> and is well commented. There are two important parts of the config file I would like to discuss. The first is the <code>upgrade type</code>. If you are doing this on a production server it might be a good idea to configure it for security upgrades. Meaning it will only update packages that are necessary for security (patching vulnerabilities). This will ensure your services stay working as expected. If you are doing this on a workstation, then it is completely up to you.</p>
<p>The second is the <code>apply_updates</code> option. This is set to no by default. So updates will download, but not install. If you want your updates to be automatically installed, then you MUST set this to yes.</p>
<div class="wp-block-image"><figure class="aligncenter size-full"><img width="689" height="475" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20689%20475'%3E%3C/svg%3E" alt="dnf-automatic configured to automatically install updates" class="wp-image-6855" data-lazy-srcset="https://www.putorius.net/wp-content/uploads/2022/04/dnf-automatic-conf-update.png.webp 689w,https://www.putorius.net/wp-content/uploads/2022/04/dnf-automatic-conf-update-300x207.png.webp 300w,https://www.putorius.net/wp-content/uploads/2022/04/dnf-automatic-conf-update-585x403.png.webp 585w" data-lazy-sizes="(max-width: 689px) 100vw, 689px" data-lazy-src="https://www.putorius.net/wp-content/uploads/2022/04/dnf-automatic-conf-update.png.webp" /><noscript><img width="689" height="475" src="https://www.putorius.net/wp-content/uploads/2022/04/dnf-automatic-conf-update.png.webp" alt="dnf-automatic configured to automatically install updates" class="wp-image-6855" srcset="https://www.putorius.net/wp-content/uploads/2022/04/dnf-automatic-conf-update.png.webp 689w,https://www.putorius.net/wp-content/uploads/2022/04/dnf-automatic-conf-update-300x207.png.webp 300w,https://www.putorius.net/wp-content/uploads/2022/04/dnf-automatic-conf-update-585x403.png.webp 585w" sizes="(max-width: 689px) 100vw, 689px" /></noscript></figure></div>
<p>In the above configuration I have the update_type set to default, and apply_updates set to yes. I have now configured my system to automatically install updates. All that is left to do is to start and enable the timer unit.</p>
<p>NOTE: If you are automatically installing updates on a production system you should configure notifications. There are 3 types of notifications you can set. Stdio, email, or you can set the <a href="https://www.putorius.net/custom-motd-login-screen-linux.html">motd (message of the day)</a>. All of these options can easily be set in the config file. Just make sure you have your <a href="https://www.putorius.net/how-to-send-mail-through-isp-smtp-with.html">system configured to send email</a> if you choose email.</p>
<h2 id="h-starting-and-enabling-the-dnf-automatic-timer-unit">Starting and Enabling the dnf-automatic Timer Unit</h2>
<p>Now that we have our configuration set, let's start and enable the timer unit. We can do this using systemctl just like we would any other service.</p>
<p>Start the timer unit:</p>
<pre class="wp-block-code"><code>&#91;<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="c7b4a6b1a8a9a687b7b2b3a8b5">[email&#160;protected]</a> ~]$ sudo systemctl start dnf-automatic.timer</code></pre>
<p>Enable the timer so it runs at boot:</p>
<pre class="wp-block-code"><code>&#91;<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b8cbd9ced7d6d9f8c8cdccd7ca">[email&#160;protected]</a> ~]$ sudo systemctl enable dnf-automatic.timer 
Created symlink /etc/systemd/system/timers.target.wants/dnf-automatic.timer → /usr/lib/systemd/system/dnf-automatic.timer.</code></pre>
<p>That's it! The dnf-automatic unit will now take care of automatically installing updates on your system.</p>
<h2 id="h-resources-and-links">Resources and Links</h2>
<ul><li><a href="https://dnf.readthedocs.io/en/latest/automatic.html">DNF Automatic Documentation</a></li></ul>
</div>
<div class="sh-page-links"></div>
<div class="post-tags-container">
<div class="post-tags">
<a class="post-tags-item post-tags-item-title">
Tags </a>
<a href="https://www.putorius.net/tag/dnf" class="post-tags-item">
#dnf </a>
<a href="https://www.putorius.net/tag/dnf-automatic" class="post-tags-item">
#dnf-automatic </a>
<a href="https://www.putorius.net/tag/security-updates" class="post-tags-item">
#security updates </a>
<a href="https://www.putorius.net/tag/updates" class="post-tags-item">
#updates </a>
</div>
<div class="sh-clear"></div>
</div>
</div>
<div class="post-switch post-swtich-style2">
<div class="row">
<div class="col-md-6">
<span class="post-switch-next text-left"> <div class="post-switch-type">Previous</div>
<h4>
Automatically Install Updates on RHEL8 or Fedora </h4>
</span>
</div>
<div class="col-md-6">
<a href="https://www.putorius.net/install-configure-and-scan-for-viruses-on-linux-with-clamav.html" class="post-switch-next text-right"> <div class="post-switch-type">Next</div>
<h4>
Install, Configure, and Scan for Viruses on Linux with ClamAV </h4>
</a>
</div>
</div>
</div>
</article>
<div class="sh-comment-form">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/automatically-install-updates-on-rhel8-or-fedora.html#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.putorius.net/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><label>Your comment <span>*</span></label>
<p class="comment-form-comment">
<textarea id="comment" name="comment" cols="45" rows="8" required></textarea>
</p><div class="sh-comment-form-column"><label>Name <span>*</span></label>
<p class="comment-form-author">
<input id="author" name="author" type="text" value="" required />
</p></div>
<div class="sh-comment-form-column"><label>Email <span>*</span></label>
<p class="comment-form-email">
<input id="email" name="email" type="text" value="" required />
</p></div>
<div class="sh-comments-required-notice">Required fields are marked <span>*</span></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Send a comment" /> <input type='hidden' name='comment_post_ID' value='6742' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e694a26f45" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="93" /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="rocketlazyloadscript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p> </div>
<div class="sh-comments">
</div>
</div>
</div>
<div id="sidebar" class="sidebar-right">
<div class="sidebar-container">
<div id="custom_html-5" class="widget_text widget-item widget_custom_html"><div class="textwidget custom-html-widget"><ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-8729877671232535" data-ad-slot="9553892499"></ins>
<script type="rocketlazyloadscript">
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="mc4wp_form_widget-3" class="widget-item widget_mc4wp_form_widget"><div class="sh-widget-title-styling"><h3 class="widget-title">Join Our Newsletter</h3></div><script type="rocketlazyloadscript">(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-2009" method="post" data-id="2009" data-name=""><div class="mc4wp-form-fields"><p>
<input type="text" name="NAME" placeholder="Name (Optional)">
</p>
<p>
<input type="email" name="EMAIL" placeholder="Email" required="">
</p>
<p>
<input type="submit" value="Subscribe">
</p>
</div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1650891121" /><input type="hidden" name="_mc4wp_form_id" value="2009" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2" /><div class="mc4wp-response"></div></form></div><div id="categories-3" class="widget-item widget_categories"><div class="sh-widget-title-styling"><h3 class="widget-title">Categories</h3></div>
<ul>
<li class="cat-item cat-item-516"><a href="https://www.putorius.net/category/bash-scripting">Bash Scripting</a> (17)
</li>
<li class="cat-item cat-item-517"><a href="https://www.putorius.net/category/basic-commands">Basic Commands</a> (50)
</li>
<li class="cat-item cat-item-7177"><a href="https://www.putorius.net/category/featured">Featured</a> (7)
</li>
<li class="cat-item cat-item-510"><a href="https://www.putorius.net/category/just-for-fun">Just for Fun</a> (5)
</li>
<li class="cat-item cat-item-508"><a href="https://www.putorius.net/category/linux-quick-tips">Linux Quick Tips</a> (96)
</li>
<li class="cat-item cat-item-504"><a href="https://www.putorius.net/category/linux-tutorials">Linux Tutorials</a> (59)
</li>
<li class="cat-item cat-item-507"><a href="https://www.putorius.net/category/misc-tech">Miscellaneous</a> (15)
</li>
<li class="cat-item cat-item-7333"><a href="https://www.putorius.net/category/network-tools">Network Tools</a> (6)
</li>
<li class="cat-item cat-item-8651"><a href="https://www.putorius.net/category/reviews">Reviews</a> (2)
</li>
<li class="cat-item cat-item-506"><a href="https://www.putorius.net/category/security">Security</a> (31)
</li>
</ul>
</div><div id="custom_html-13" class="widget_text widget-item widget_custom_html"><div class="textwidget custom-html-widget"><ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-8729877671232535" data-ad-slot="9339030055"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> </div>
</div>
</div>
</div>
</div>
<footer class="sh-footer">
<div class="sh-copyrights sh-copyrights-align-left">
<div class="container container-padding">
<div class="sh-table">
<div class="sh-table-cell">
<div class="sh-copyrights-info">
<span>© 2010-2020 Putorius - All Rights Reserved</span>
</div>
</div>
<div class="sh-table-cell">
<div class="sh-nav-container"><ul id="menu-footer-menu" class="sh-nav"><li id="menu-item-5869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5869"><a href="https://www.putorius.net" data-ps2id-api="true">HOME</a></li>
<li id="menu-item-531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-531"><a href="https://www.putorius.net/privacy-policy" data-ps2id-api="true">Privacy Policy</a></li>
<li id="menu-item-2769" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2769"><a href="https://www.putorius.net/about-putorius" data-ps2id-api="true">About</a></li>
<li id="menu-item-282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-282"><a href="https://www.putorius.net/contact-us" data-ps2id-api="true">CONTACT</a></li>
<li id="menu-item-407" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-407"><a href="https://www.putorius.net/search" data-ps2id-api="true">SEARCH</a></li>
<li id="menu-item-2068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2068"><a href="https://www.putorius.net/newsletter" data-ps2id-api="true">Newsletter</a></li>
<li id="menu-item-3181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3181"><a href="https://www.putorius.net/videos" data-ps2id-api="true">Videos</a></li>
</ul></div>
</div>
</div>
</div>
</div>
</footer>
</div>
<div id="login-register" style="display: none;">
<div class="sh-login-popup-tabs">
<ul class="nav nav-tabs">
<li class="active">
<a data-target="#viens" data-toggle="tab">Login</a>
</li>
<li>
<a data-target="#divi" data-toggle="tab">Register</a>
</li>
</ul>
</div>
<div class="tab-content">
<div class="tab-pane active" id="viens">
<div class="sh-login-popup-content sh-login-popup-content-login">
<form name="loginform" id="loginform" action="https://www.putorius.net/wp-login.php" method="post"><p class="login-username">
<label for="user_login">Username or Email Address</label>
<input type="text" name="log" id="user_login" class="input" value="" size="20" />
</p><p class="login-password">
<label for="user_pass">Password</label>
<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
</p><a href="/wp-login.php?action=lostpassword" class="login-forgot-password">Forgot Password</a><p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p><p class="login-submit">
<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
<input type="hidden" name="redirect_to" value="https://www.putorius.net/automatically-install-updates-on-rhel8-or-fedora.html" />
</p></form> </div>
</div>
<div class="tab-pane" id="divi">
<div class="sh-login-popup-content">
<p id="reg_passmail">Registration is closed.</p>
</div>
</div>
</div>
</div>
</div>
<script type="rocketlazyloadscript">(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>
<script type='text/javascript' id='page-scroll-to-id-plugin-script-js-extra'>
/* <![CDATA[ */
var mPS2id_params = {"instances":{"mPS2id_instance_0":{"selector":"a[href*='#']:not([href='#'])","autoSelectorMenuLinks":"true","excludeSelector":"a[href^='#tab-'], a[href^='#tabs-'], a[data-toggle]:not([data-toggle='tooltip']), a[data-slide], a[data-vc-tabs], a[data-vc-accordion], a.screen-reader-text.skip-link","scrollSpeed":800,"autoScrollSpeed":"true","scrollEasing":"easeInOutQuint","scrollingEasing":"easeOutQuint","forceScrollEasing":"false","pageEndSmoothScroll":"true","stopScrollOnUserAction":"false","autoCorrectScroll":"false","autoCorrectScrollExtend":"true","layout":"vertical","offset":"100","dummyOffset":"false","highlightSelector":"","clickedClass":"mPS2id-clicked","targetClass":"mPS2id-target","highlightClass":"mPS2id-highlight","forceSingleHighlight":"false","keepHighlightUntilNext":"false","highlightByNextTarget":"false","appendHash":"true","scrollToHash":"true","scrollToHashForAll":"true","scrollToHashDelay":0,"scrollToHashUseElementData":"true","scrollToHashRemoveUrlHash":"false","disablePluginBelow":0,"adminDisplayWidgetsId":"true","adminTinyMCEbuttons":"true","unbindUnrelatedClickEvents":"false","unbindUnrelatedClickEventsSelector":"","normalizeAnchorPointTargets":"false","encodeLinks":"false"}},"total_instances":"1","shortcode_class":"_ps2id"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.putorius.net/wp-content/plugins/page-scroll-to-id/js/page-scroll-to-id.min.js?ver=1.7.5' id='page-scroll-to-id-plugin-script-js' defer></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/videos|\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin|\/logout|\/wp-login.php|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.putorius.net","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' src='https://www.putorius.net/wp-includes/js/jquery/ui/effect.min.js?ver=1.13.1' id='jquery-effects-core-js' defer></script>
<script type='text/javascript' src='https://www.putorius.net/wp-content/themes/gillion/js/plugins/bootstrap.min.js?ver=3.3.4' id='bootstrap-js' defer></script>
<script type='text/javascript' src='https://www.putorius.net/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js' defer></script>
<script data-minify="1" type='text/javascript' defer src='https://www.putorius.net/wp-content/cache/min/1/wp-content/plugins/mailchimp-for-wp/assets/js/forms.js?ver=1650242203' id='mc4wp-forms-api-js'></script>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript" id="slb_context">window.addEventListener('DOMContentLoaded', function() {/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */});</script>
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">window.addEventListener('DOMContentLoaded', function() { jQuery(document).ready(function ($) { "use strict"; }); });</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.putorius.net/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"701b5f511b835dd4","version":"2021.12.0","r":1,"token":"e12d775884c94ebea6bd2cff8b0a6538","si":100}' crossorigin="anonymous"></script>
</body>
</html>
