<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><title>Cluster SSH - Manage Multiple Linux Servers Simultaneously - Putorius</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%2C400italic%2C700italic%7CMontserrat%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2Cregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&subset=latin&display=swap" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="https://www.putorius.net/wp-content/cache/min/1/6f8828caa1b4bc09dd0f700cd5269d2e.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="description" content="How to manage multiple Linux servers simultaneously with Cluster SSH. Learn how to create custom cluster and tag files, command line options and more." /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.putorius.net/cluster-ssh.html" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Cluster SSH - Manage Multiple Linux Servers Simultaneously - Putorius" /><meta property="og:description" content="How to manage multiple Linux servers simultaneously with Cluster SSH. Learn how to create custom cluster and tag files, command line options and more." /><meta property="og:url" content="https://www.putorius.net/cluster-ssh.html" /><meta property="og:site_name" content="Putorius" /><meta property="article:publisher" content="https://www.facebook.com/putorius.net" /><meta property="article:tag" content="server management" /><meta property="article:tag" content="ssh" /><meta property="article:tag" content="system administration" /><meta property="article:section" content="Linux Tutorials" /><meta property="article:published_time" content="2019-10-28T02:12:38+00:00" /><meta property="article:modified_time" content="2019-11-01T20:19:51+00:00" /><meta property="og:updated_time" content="2019-11-01T20:19:51+00:00" /><meta property="fb:app_id" content="292441191418366" /><meta property="og:image" content="https://www.putorius.net/wp-content/uploads/2019/10/ClusterSSH-feat-social-min.png" /><meta property="og:image:secure_url" content="https://www.putorius.net/wp-content/uploads/2019/10/ClusterSSH-feat-social-min.png" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="700" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="How to manage multiple Linux servers simultaneously with Cluster SSH. Learn how to create custom cluster and tag files, command line options and more." /><meta name="twitter:title" content="Cluster SSH - Manage Multiple Linux Servers Simultaneously - Putorius" /><meta name="twitter:site" content="@CuriousPutorius" /><meta name="twitter:image" content="https://www.putorius.net/wp-content/uploads/2019/10/ClusterSSH-feat-social-min.png" /><meta name="twitter:creator" content="@CuriousPutorius" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.putorius.net/#organization","name":"Putorius","url":"https://www.putorius.net/","sameAs":["https://www.facebook.com/putorius.net","https://www.youtube.com/channel/UCV9kD9xTuORCE9TDxHwY1uQ","https://twitter.com/CuriousPutorius"],"logo":{"@type":"ImageObject","@id":"https://www.putorius.net/#logo","url":"https://www.putorius.net/wp-content/uploads/2019/01/logo-only-min.png","width":800,"height":800,"caption":"Putorius"},"image":{"@id":"https://www.putorius.net/#logo"}},{"@type":"WebSite","@id":"https://www.putorius.net/#website","url":"https://www.putorius.net/","name":"Putorius","description":"Linux Tutorials, How-tos, and General Information.","publisher":{"@id":"https://www.putorius.net/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.putorius.net/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.putorius.net/cluster-ssh.html#primaryimage","url":"https://www.putorius.net/wp-content/uploads/2019/10/ClusterSSH-feat-no-text-min.png","width":1200,"height":700},{"@type":"WebPage","@id":"https://www.putorius.net/cluster-ssh.html#webpage","url":"https://www.putorius.net/cluster-ssh.html","inLanguage":"en-US","name":"Cluster SSH - Manage Multiple Linux Servers Simultaneously - Putorius","isPartOf":{"@id":"https://www.putorius.net/#website"},"primaryImageOfPage":{"@id":"https://www.putorius.net/cluster-ssh.html#primaryimage"},"datePublished":"2019-10-28T02:12:38+00:00","dateModified":"2019-11-01T20:19:51+00:00","description":"How to manage multiple Linux servers simultaneously with Cluster SSH. Learn how to create custom cluster and tag files, command line options and more."},{"@type":"NewsArticle","@id":"https://www.putorius.net/cluster-ssh.html#article","isPartOf":{"@id":"https://www.putorius.net/cluster-ssh.html#webpage"},"author":{"@id":"https://www.putorius.net/#/schema/person/7f69ef7a38c21fbd24c500aab8c5138c"},"headline":"Cluster SSH - Manage Multiple Linux Servers Simultaneously","datePublished":"2019-10-28T02:12:38+00:00","dateModified":"2019-11-01T20:19:51+00:00","commentCount":"6","mainEntityOfPage":{"@id":"https://www.putorius.net/cluster-ssh.html#webpage"},"publisher":{"@id":"https://www.putorius.net/#organization"},"image":{"@id":"https://www.putorius.net/cluster-ssh.html#primaryimage"},"keywords":"server management,ssh,system administration","articleSection":"Linux Tutorials","copyrightYear":"2019","copyrightHolder":{"@id":"https://www.putorius.net/#organization"}},{"@type":["Person"],"@id":"https://www.putorius.net/#/schema/person/7f69ef7a38c21fbd24c500aab8c5138c","name":"Steven Vona","description":"Steven Vona is a Linux administrator whose passion for technology extends beyond the day to day and into a love of teaching his skills to others. Steven is trained and certified in multiple technologies, including Microsoft Windows, Linux, VMWare and Cybersecurity, and has over 16 years of experience working in both the public and private sectors. Because Steven did not complete a traditional educational path, he is mostly self-taught and a strong believer in learning by experimentation. Steven began to teach himself programming at age 12 and ran a BBS in 1988; when teaching, he encourages others to try different solutions and learn from their mistakes and successes.\u00a0 Outside of technology, Steven is an animal lover and an avid photographer who enjoys exploring and photographing his native city, Philadelphia.","sameAs":[]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//fonts.gstatic.com' /><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /><link rel='dns-prefetch' href='//apis.google.com' /><link rel='dns-prefetch' href='//googletagservices.com' /><link rel='dns-prefetch' href='//gstatic.com' /><link rel='dns-prefetch' href='//adservice.google.com' /><link rel="alternate" type="application/rss+xml" title="Putorius &raquo; Feed" href="https://www.putorius.net/feed" /><link rel="alternate" type="application/rss+xml" title="Putorius &raquo; Comments Feed" href="https://www.putorius.net/comments/feed" /><link rel="alternate" type="application/rss+xml" title="Putorius &raquo; Cluster SSH - Manage Multiple Linux Servers Simultaneously Comments Feed" href="https://www.putorius.net/cluster-ssh.html/feed" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><style id='gillion-responsive-inline-css' type='text/css'></style> <script type='text/javascript' src='https://www.putorius.net/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var ai_front = {"wp_ai":"5.3.2+2.6.2","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN","fallback":"FALLBACK","automatically_placed":"Automatically placed by AdSense Auto ads code"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var gillion_loadmore_posts = {"ajax_url":"https:\/\/www.putorius.net\/wp-admin\/admin-ajax.php"};
var gillion = {"siteurl":"https:\/\/www.putorius.net\/","loggedin":"","page_loader":"0","notice":"enable","header_animation_dropdown_delay":"1000","header_animation_dropdown":"easeOutQuint","header_animation_dropdown_speed":"300","lightbox_opacity":"0.88","lightbox_transition":"elastic","page_numbers_prev":"Previous","page_numbers_next":"Next","rtl_support":"","footer_parallax":"","social_share":"\"\"","text_show_all":"Show All"}; /* ]]> */</script> <link rel='https://api.w.org/' href='https://www.putorius.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.putorius.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.putorius.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://www.putorius.net/?p=3385' /><link rel="alternate" type="application/json+oembed" href="https://www.putorius.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.putorius.net%2Fcluster-ssh.html" /><link rel="alternate" type="text/xml+oembed" href="https://www.putorius.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.putorius.net%2Fcluster-ssh.html&#038;format=xml" /><style>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</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." /><link rel="amphtml" href="https://www.putorius.net/cluster-ssh.html/amp"><link rel="icon" href="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-180x180.png" /><meta name="msapplication-TileImage" content="https://www.putorius.net/wp-content/uploads/2019/11/cropped-favicon-270x270.png" /><style type="text/css" id="wp-custom-css">body{background:url(https://www.putorius.net/wp-content/uploads/2020/01/tesoro-putorius.jpg) bottom right no-repeat fixed}#sidebar .theiaStickySidebar{position:static!important;transform:none!important}.container.sh-header-additional{padding:1!important}.sh-header-banner-container br{display:none}body #page-container a.post-title h2{font-size:22px}.sh-header-mobile-dropdown{top:-21px}pre{background:rgba(232,232,232,1);color:rgba(0,0,0,1);border-top-left-radius:0;border-bottom-left-radius:0;border-top-right-radius:10px;border-bottom-right-radius:10px;border-left:3px solid #cf783f}.blog_sec_first a.post-title h2{font-size:30px!important}.blog_sec_second a.post-title h2{font-size:16px!important;font-weight:700}.sh-404-overay{display:none}.sh-404-title{display:none}.resp-container{position:relative;overflow:hidden;padding-top:56.25%}.resp-iframe{position:absolute;top:0;left:0;width:100%;height:100%;border:0}</style><noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><style>.ai-viewports{--ai:1}.ai-viewport-3{display:none!important}.ai-viewport-2{display:none!important}.ai-viewport-1{display:inherit!important}.ai-viewport-0{display:none!important}@media (min-width:768px) and (max-width:979px){.ai-viewport-1{display:none!important}.ai-viewport-2{display:inherit!important}}@media (max-width:767px){.ai-viewport-1{display:none!important}.ai-viewport-3{display:inherit!important}}</style> <script data-no-minify="1" async src="https://www.putorius.net/wp-content/cache/busting/1/gtm-e93427d5df71d62efa6405f50f7b5aff.js"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-109866879-1');</script><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body class="post-template-default single single-post postid-3385 single-format-standard singular sh-body-header-sticky sh-title-style1 sh-section-tabs-style1 sh-carousel-style1 sh-carousel-position-title sh-post-categories-style1 sh-review-style2 sh-meta-order-bottom sh-instagram-widget-columns2 sh-categories-position-title sh-media-icon-style1 sh-wc-labels-off wpb-js-composer js-comp-ver-6.1 vc_responsive"><div class="sh-header-side"><div id="mc4wp_form_widget-2" class="widget-item widget_mc4wp_form_widget"><div class="sh-widget-title-styling"><h3 class="widget-title">Sign Up For Our Newsletter</h3></div><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-2009" method="post" data-id="2009" data-name=""><div class="mc4wp-form-fields"><p> <input type="text" name="NAME" placeholder="Name (Optional)"></p><p> <input type="email" name="EMAIL" placeholder="Email" required=""></p><p> <input type="submit" value="Subscribe"></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1580542324" /><input type="hidden" name="_mc4wp_form_id" value="2009" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></div></div><div class="sh-header-side-overlay"></div><div id="page-container" class=""><div class="sh-page-notice"><div class="container"><div class="sh-table"><div class="sh-table-cell"> <span style="font-size: 13px">If you continue to browse or click Accept, you agree to the storing of cookies on your device. To learn more about why we use cookies, please see our <a href="https://www.putorius.net/privacy-policy#cookies">cookie policy</a>.</span></div><div class="sh-table-cell text-right"> <a href="#" class="sh-page-notice-button"> Accept </a></div></div></div></div><header class="primary-mobile"><div id="header-mobile" class="sh-header-mobile"><div class="sh-header-mobile-navigation"><div class="container"><div class="sh-table sh-header-mobile-table"><div class="sh-table-cell"><nav id="header-navigation-mobile" class="header-standard-position sh-header-mobile-navigation-left"><div class="sh-nav-container"><ul class="sh-nav"><li><div class="sh-hamburger-menu sh-nav-dropdown"> <span></span> <span></span> <span></span> <span></span></div></li></ul></div></nav></div><div class="sh-table-cell sh-header-logo-container"><div class="header-logo"> <a href="https://www.putorius.net/" class="header-logo-container sh-table-small"><div class="sh-table-cell"> <img class="sh-standard-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-standard-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript> <img class="sh-sticky-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-sticky-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript> <img class="sh-light-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-light-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript></div> </a></div></div><div class="sh-table-cell"><nav class="header-standard-position sh-header-mobile-navigation-right"><div class="sh-nav-container"><ul class="sh-nav"></ul></div></nav></div></div></div></div><nav class="sh-header-mobile-dropdown"><div class="container sh-nav-container"><ul class="sh-nav-mobile"></ul></div><div class="container sh-nav-container"></div></nav></div></header><header class="primary-desktop"><div class="sh-header-height sh-header-3"><div class="sh-header-middle"><div class="container sh-header-additional"><div class="sh-table"><div class="sh-table-cell sh-header-logo-container"><nav class="header-standard-position"><div class="sh-nav-container"><ul class="sh-nav sh-nav-left"><li><div class="header-logo"> <a href="https://www.putorius.net/" class="header-logo-container sh-table-small"><div class="sh-table-cell"> <img class="sh-standard-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-standard-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript> <img class="sh-sticky-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-sticky-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript> <img class="sh-light-logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Putorius" data-lazy-src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" /><noscript><img class="sh-light-logo" src="//www.putorius.net/wp-content/uploads/2019/10/site-logo-small.png" alt="Putorius" /></noscript></div> </a></div></li></ul></div></nav></div><div class="sh-table-cell sh-header-banner-container"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display:inline-block;width:970px;height:90px" data-ad-client="ca-pub-8729877671232535" data-ad-slot="5546925678"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></div></div><div class="sh-header sh-header-3 sh-sticky-header"><div class="container"><div class="sh-table"><div class="sh-table-cell sh-header-nav-container"><nav id="header-navigation" class="header-standard-position"><div class="sh-nav-container"><ul id="menu-main" class="sh-nav"><li id="menu-item-130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-130"><a href="https://www.putorius.net" data-ps2id-api="true">Home</a></li><li id="menu-item-389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-389"><a href="https://www.putorius.net/search" data-ps2id-api="true">Search</a></li><li id="menu-item-174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174"><a href="https://www.putorius.net/contact-us" data-ps2id-api="true">Contact</a></li><li id="menu-item-2642" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2642"><a href="https://www.putorius.net/newsletter" data-ps2id-api="true">Newsletter</a></li><li id="menu-item-3180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3180"><a href="https://www.putorius.net/videos" data-ps2id-api="true">Videos</a></li></ul></div></nav></div><div class="sh-table-cell sh-header-meta-container"><nav class="header-standard-position"><div class="sh-nav-container"><ul class="sh-nav"></ul></div></nav></div></div></div><div class="sh-header-search-side"><div class="sh-header-search-side-container"><form method="get" class="sh-header-search-form" action="https://www.putorius.net/"> <input type="text" value="" name="s" class="sh-header-search-side-input" placeholder="Enter a keyword to search..." /><div class="sh-header-search-side-close"> <i class="ti-close"></i></div><div class="sh-header-search-side-icon"> <i class="ti-search"></i></div></form></div></div></div></div></header><div class="blog-slider blog-slider-style3 3385" style="position: relative;"><div class="blog-slider-list slick-initialized"><div data-bg="url(https://www.putorius.net/wp-content/uploads/2019/10/ClusterSSH-feat-no-text-min.png)" class="blog-slider-item rocket-lazyload" style=""><div class="blog-slider-container"><div class="blog-slider-content"><div class="blog-slider-content-icon"> <i class="icon icon-pencil"></i></div><div class="blog-slider-content-details"><div class="post-categories-container"><div class="post-categories"><a href="https://www.putorius.net/category/linux-tutorials">Linux Tutorials</a></div></div><h1 class="post-title"> Cluster SSH - Manage Multiple Linux Servers Simultaneously</h1><div class="post-meta"><div class="post-meta-content"> <span class="post-auhor-date post-auhor-date-full"> <a href="https://www.putorius.net/author/savona"> </a> <span> <a href="https://www.putorius.net/author/savona" class="post-author">Steven Vona</a></span>, <a href="https://www.putorius.net/cluster-ssh.html" class="post-date"> October 27, 2019 </a> </span> <a href="https://www.putorius.net/cluster-ssh.html#comments" class="post-comments"> <i class="icon icon-bubble"></i> 6 </a> <span class="post-readtime"> <i class="icon icon-clock"></i> 8 min <span>read</span> </span> <span class="placeholder-post-read-later"></span></div></div></div></div></div></div></div><div class="blog-slider-dots"></div></div><div id="wrapper" class="layout-default"><div class="content-container sh-page-layout-default"><div class="container entry-content"><div id="content-wrapper" class="content-wrapper-with-sidebar"><div id="content" class="content-layout-sidebar-right content-with-sidebar-right"><div class="blog-single blog-style-single blog-blockquote-style1 blog-style-post-slider"><article id="post-3385" class="post-item post-item-single post-3385 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-tutorials tag-server-management tag-ssh tag-system-administration"><meta content="https://www.putorius.net/wp-content/uploads/2019/10/ClusterSSH-feat-no-text-min-1024x597.png" itemprop="image" /><div class="post-item-single-container"><div class="post-content post-single-content"><p>Cluster SSH (cssh) is a utility that allows you to manage multiple servers over SSH from a single administration console. It was originally designed to work with multiple nodes that make up a HPC (High Performance Computing) cluster. These nodes are usually configured identically, therefore requiring the same administrative command to be run on each node. Using Cluster SSH allows an administrator to type a command into a single console and have it replicated over many systems.</p><p>As a SysAdmin this tool can be a huge time saver. In this article we will discuss how to install, configure and use Cluster SSH.</p><div class='code-block code-block-7 ai-viewport-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="" data-class="Y29kZS1ibG9jaw=="></div></div><center><figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"> <iframe loading="lazy" title="Cluster SSH - Manage Multiple Linux Servers Simultaneously" width="500" height="281" src="about:blank" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.youtube.com/embed/3S3_hsqpYg4?feature=oembed"></iframe><noscript><iframe title="Cluster SSH - Manage Multiple Linux Servers Simultaneously" width="500" height="281" src="https://www.youtube.com/embed/3S3_hsqpYg4?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></noscript></div></figure></center><div id="ez-toc-container" class="counter-hierarchy counter-decimal ez-toc-transparent"><div class="ez-toc-title-container"><p class="ez-toc-title">Table of Contents</p> <span class="ez-toc-title-toggle"></span></div><nav><ul class="ez-toc-list"><li><a href="#how-to-install-cluster-ssh" title="How to Install Cluster SSH">How to Install Cluster SSH</a><ul><li><a href="#fedora-installation-of-cluster-ssh" title="Fedora installation of Cluster SSH">Fedora installation of Cluster SSH</a></li><li><a href="#centos-red-hat-installation-of-cluster-ssh" title="CentOS / Red Hat installation of Cluster SSH">CentOS / Red Hat installation of Cluster SSH</a></li><li><a href="#ubuntu-debian-installation-of-cluster-ssh" title="Ubuntu / Debian installation of Cluster SSH ">Ubuntu / Debian installation of Cluster SSH </a></li></ul></li><li><a href="#how-to-configure-cluster-ssh" title="How to Configure Cluster SSH">How to Configure Cluster SSH</a><ul><li><a href="#global-configuration-files" title="Global Configuration Files">Global Configuration Files</a></li><li><a href="#user-specific-configuration-files" title="User Specific Configuration Files">User Specific Configuration Files</a></li><li><a href="#configure-the-clusters-file" title="Configure The Clusters File">Configure The Clusters File</a></li><li><a href="#configuring-the-tag-file" title="Configuring The Tag File">Configuring The Tag File</a></li><li><a href="#cluster-ssh-configuration-file" title="Cluster SSH Configuration File ">Cluster SSH Configuration File </a></li></ul></li><li><a href="#basic-usage-of-cluster-ssh" title="Basic Usage of Cluster SSH">Basic Usage of Cluster SSH</a></li><li><a href="#connecting-to-groups-of-servers-using-tags" title="Connecting to Groups of Servers Using Tags">Connecting to Groups of Servers Using Tags</a></li><li><a href="#using-the-administration-console-options" title="Using the Administration Console Options">Using the Administration Console Options</a></li><li><a href="#using-cssh-command-line-options" title="Using cssh Command Line Options">Using cssh Command Line Options</a><ul><li><a href="#specify-user-on-per-host-basis" title="Specify User on Per Host Basis">Specify User on Per Host Basis</a></li><li><a href="#run-command-upon-login" title="Run Command Upon Login">Run Command Upon Login</a></li><li><a href="#resize-terminal-windows-to-fill-screen" title="Resize Terminal Windows to Fill Screen">Resize Terminal Windows to Fill Screen</a></li></ul></li><li><a href="#potential-for-catastrophes" title="Potential for Catastrophes">Potential for Catastrophes</a></li><li><a href="#conclusion" title="Conclusion">Conclusion</a></li><li><a href="#resources-and-links" title="Resources and Links">Resources and Links</a></li></ul></nav></div><h2><span class="ez-toc-section" id="how-to-install-cluster-ssh">How to Install Cluster SSH</span></h2><p>Cluster SSH is simple to install and available on most Linux distributions. Using your package manager makes installation simple and quick.</p><h3><span class="ez-toc-section" id="fedora-installation-of-cluster-ssh">Fedora installation of Cluster SSH</span></h3><pre class="wp-block-preformatted">sudo dnf install clusterssh -y</pre><h3><span class="ez-toc-section" id="centos-red-hat-installation-of-cluster-ssh">CentOS / Red Hat installation of Cluster SSH</span></h3><pre class="wp-block-preformatted">sudo yum install clusterssh -y</pre><h3><span class="ez-toc-section" id="ubuntu-debian-installation-of-cluster-ssh">Ubuntu / Debian installation of Cluster SSH </span></h3><pre class="wp-block-preformatted">sudo apt-get install clusterssh</pre><h2><span class="ez-toc-section" id="how-to-configure-cluster-ssh">How to Configure Cluster SSH</span></h2><p>HPC Cluster Administrators often have very complex configurations that involve several different files, tags, and options. Such a complex configuration is outside the scope of this article (see resources section).</p><p>Cluster SSH can be configured through it's global configuration files, or user specific configuration files. Both files use the same format, the only difference is one effects all users and the other is specific to one user. For this tutorial we will be making all changes to the user configurations.</p><p>In the interest of keeping this article precise, we will focus on the most popular configurations to quickly get you up and running.</p><div class='code-block code-block-8 ai-viewport-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="" data-class="Y29kZS1ibG9jaw=="></div></div><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="PGlucyBjbGFzcz0iYWRzYnlnb29nbGUiCiAgICAgc3R5bGU9ImRpc3BsYXk6YmxvY2s7IHRleHQtYWxpZ246Y2VudGVyOyIKICAgICBkYXRhLWFkLWxheW91dD0iaW4tYXJ0aWNsZSIKICAgICBkYXRhLWFkLWZvcm1hdD0iZmx1aWQiCiAgICAgZGF0YS1hZC1jbGllbnQ9ImNhLXB1Yi04NzI5ODc3NjcxMjMyNTM1IgogICAgIGRhdGEtYWQtc2xvdD0iNDk3MzM3Nzg5MSI+PC9pbnM+CjxzY3JpcHQ+CiAgICAgKGFkc2J5Z29vZ2xlID0gd2luZG93LmFkc2J5Z29vZ2xlIHx8IFtdKS5wdXNoKHt9KTsKPC9zY3JpcHQ+" data-class="Y29kZS1ibG9jaw=="></div></div><div class='code-block code-block-2 ai-viewport-2' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="PCEtLSBQdXRvcml1cyBNb2JpbGUgSGVhZGVyIC0tPgo8aW5zIGNsYXNzPSJhZHNieWdvb2dsZSIKICAgICBzdHlsZT0iZGlzcGxheTppbmxpbmUtYmxvY2s7d2lkdGg6MzIwcHg7aGVpZ2h0OjEwMHB4IgogICAgIGRhdGEtYWQtY2xpZW50PSJjYS1wdWItODcyOTg3NzY3MTIzMjUzNSIKICAgICBkYXRhLWFkLXNsb3Q9IjI4NDI5NTk0MTEiPjwvaW5zPgo8c2NyaXB0PgooYWRzYnlnb29nbGUgPSB3aW5kb3cuYWRzYnlnb29nbGUgfHwgW10pLnB1c2goe30pOwo8L3NjcmlwdD4=" data-class="Y29kZS1ibG9jaw=="></div></div><h3><span class="ez-toc-section" id="global-configuration-files">Global Configuration Files</span></h3><p>There are three global configuration files. Two are more of map files (like /etc/hosts or /etc/auto.master) than actual configuration files.</p><ul><li>/etc/clusters - Contains a list of tags (cluster names) and the hosts mapped to the specified tag.</li><li>/etc/tags - Reversed logic to /etc/clusters. This allows you to specify one host as a member of multiple tags (clusters).</li><li>/etc/csshrc - This file contains default configuration overrides.</li></ul><h3><span class="ez-toc-section" id="user-specific-configuration-files">User Specific Configuration Files</span></h3><p>There are also three user specific files that directly map to the global files.</p><ul><li>$HOME/.clusterssh/clusters - User specific version of /etc/clusters</li><li>$HOME/.clusterssh/tags - User specific version of /etc/tags</li><li>$HOME/.clusterssh/config - Users specific version of /etc/csshrc</li></ul><p></p><h3><span class="ez-toc-section" id="configure-the-clusters-file">Configure The Clusters File</span></h3><p><em>/etc/clusters (global)</em> or <em>$HOME/.clusterssh/clusters (user specific)</em></p><p>The cluster file format is simply a tag (cluster name) followed by the name of the hosts in said cluster, each separated by a space.</p><p>For an example, let's say we have six servers. Two are development servers and four are production servers. We can specify the tag "dev" and then list the development servers. Then do the same for the production servers.</p><p>Here is an example clusters file:</p><div class='code-block code-block-8 ai-viewport-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="" data-class="Y29kZS1ibG9jaw=="></div></div><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="PGlucyBjbGFzcz0iYWRzYnlnb29nbGUiCiAgICAgc3R5bGU9ImRpc3BsYXk6YmxvY2s7IHRleHQtYWxpZ246Y2VudGVyOyIKICAgICBkYXRhLWFkLWxheW91dD0iaW4tYXJ0aWNsZSIKICAgICBkYXRhLWFkLWZvcm1hdD0iZmx1aWQiCiAgICAgZGF0YS1hZC1jbGllbnQ9ImNhLXB1Yi04NzI5ODc3NjcxMjMyNTM1IgogICAgIGRhdGEtYWQtc2xvdD0iNDk3MzM3Nzg5MSI+PC9pbnM+CjxzY3JpcHQ+CiAgICAgKGFkc2J5Z29vZ2xlID0gd2luZG93LmFkc2J5Z29vZ2xlIHx8IFtdKS5wdXNoKHt9KTsKPC9zY3JpcHQ+" data-class="Y29kZS1ibG9jaw=="></div></div><div class='code-block code-block-2 ai-viewport-2' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="PCEtLSBQdXRvcml1cyBNb2JpbGUgSGVhZGVyIC0tPgo8aW5zIGNsYXNzPSJhZHNieWdvb2dsZSIKICAgICBzdHlsZT0iZGlzcGxheTppbmxpbmUtYmxvY2s7d2lkdGg6MzIwcHg7aGVpZ2h0OjEwMHB4IgogICAgIGRhdGEtYWQtY2xpZW50PSJjYS1wdWItODcyOTg3NzY3MTIzMjUzNSIKICAgICBkYXRhLWFkLXNsb3Q9IjI4NDI5NTk0MTEiPjwvaW5zPgo8c2NyaXB0PgooYWRzYnlnb29nbGUgPSB3aW5kb3cuYWRzYnlnb29nbGUgfHwgW10pLnB1c2goe30pOwo8L3NjcmlwdD4=" data-class="Y29kZS1ibG9jaw=="></div></div><pre class="wp-block-preformatted"># Development servers
dev savona@centosdev savona@fenrir

# Production Servers
prod savona@putorweb1 savona@putorweb2 savona@putorweb3 savona@putorweb4</pre><p>NOTE: Adding the username (user@host) is optional. You can specify the username on the command line. If you username is the same on all systems you can exclude it entirely.</p><p>Now that we have the clusters file created, we can just use the tag to open terminals for the two dev servers listed.</p><pre class="wp-block-preformatted">[savona@putor ~]$ cssh dev</pre><p>The above command would open two XTerm windows, one for each development server listed after the dev tag.</p><h3><span class="ez-toc-section" id="configuring-the-tag-file">Configuring The Tag File</span></h3><p><em>/etc/tags (global)</em> or <em>$HOME/.clusterssh/tags (user specific)</em></p><p>As stated above, the tag file uses the reverse format of the clusters file. In the tags file, you have a host followed by one or more tags, each separated by a space. This allows for more granular control over the clusters.</p><p>In this example, let's say we want to group servers by their OS and location. We could start the line with a host, then list the tags (clusters) that host should be associated with. This allows us to easily specify a single host as a member of several tags (clusters).</p><p>Here is an example of seperating our hosts by operating system and location.</p><div class='code-block code-block-8 ai-viewport-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="" data-class="Y29kZS1ibG9jaw=="></div></div><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="PGlucyBjbGFzcz0iYWRzYnlnb29nbGUiCiAgICAgc3R5bGU9ImRpc3BsYXk6YmxvY2s7IHRleHQtYWxpZ246Y2VudGVyOyIKICAgICBkYXRhLWFkLWxheW91dD0iaW4tYXJ0aWNsZSIKICAgICBkYXRhLWFkLWZvcm1hdD0iZmx1aWQiCiAgICAgZGF0YS1hZC1jbGllbnQ9ImNhLXB1Yi04NzI5ODc3NjcxMjMyNTM1IgogICAgIGRhdGEtYWQtc2xvdD0iNDk3MzM3Nzg5MSI+PC9pbnM+CjxzY3JpcHQ+CiAgICAgKGFkc2J5Z29vZ2xlID0gd2luZG93LmFkc2J5Z29vZ2xlIHx8IFtdKS5wdXNoKHt9KTsKPC9zY3JpcHQ+" data-class="Y29kZS1ibG9jaw=="></div></div><div class='code-block code-block-2 ai-viewport-2' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="PCEtLSBQdXRvcml1cyBNb2JpbGUgSGVhZGVyIC0tPgo8aW5zIGNsYXNzPSJhZHNieWdvb2dsZSIKICAgICBzdHlsZT0iZGlzcGxheTppbmxpbmUtYmxvY2s7d2lkdGg6MzIwcHg7aGVpZ2h0OjEwMHB4IgogICAgIGRhdGEtYWQtY2xpZW50PSJjYS1wdWItODcyOTg3NzY3MTIzMjUzNSIKICAgICBkYXRhLWFkLXNsb3Q9IjI4NDI5NTk0MTEiPjwvaW5zPgo8c2NyaXB0PgooYWRzYnlnb29nbGUgPSB3aW5kb3cuYWRzYnlnb29nbGUgfHwgW10pLnB1c2goe30pOwo8L3NjcmlwdD4=" data-class="Y29kZS1ibG9jaw=="></div></div><pre class="wp-block-preformatted">savona@putorweb1 centos phila
savona@putorweb2 redhat denver
savona@putorweb3 redhat phila
savona@putorweb4 centos denver</pre><p>We effectively made the host putorweb1 a member for two clusters. One called centos and the other called phila. We can now connect to all the hosts in the Philadelphia datacenter by using this tag like so:</p><pre class="wp-block-preformatted">[savona@putor ~]$ cssh phila
 Opening to: savona@putorweb1 savona@putorweb3</pre><p>Likewise, we can also connect to all the CentOS systems using the centos tag:</p><pre class="wp-block-preformatted">[savona@putor ~]$ cssh centos
 Opening to: savona@putorweb1 savona@putorweb4</pre><h3><span class="ez-toc-section" id="cluster-ssh-configuration-file">Cluster SSH Configuration File </span></h3><p><em>/etc/csshrc (global)</em> or <em>$HOME/.clusterssh/config (user specific)</em></p><p>The main configuration file provides a method for overriding the default behavior of the program. The format is similar to the other configuration files, one option and value per line. Here is an example config file:</p><pre class="wp-block-preformatted"># Close terminal window after 3 seconds
auto_close = 3
# Set initial console position
console_position = +0+200
# Hide console menu
hide_menu = 1</pre><p>For a full list of options, see the man page in the resources section.</p><h2><span class="ez-toc-section" id="basic-usage-of-cluster-ssh">Basic Usage of Cluster SSH</span></h2><p>Using Cluster SHH is simple and can be done with no configuration at all.</p><figure class="wp-block-image"><a href="https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min.png" data-slb-active="1" data-slb-asset="2000272948" data-slb-internal="0"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Screenshot showing clusterssh being used to open multiple terminal windows on Fedora Linux" class="wp-image-3547" data-lazy-srcset="https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-1024x648.png 1024w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-300x190.png 300w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-768x486.png 768w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-420x265.png 420w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-585x370.png 585w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min.png 1167w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-1024x648.png" /><noscript><img src="https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-1024x648.png" alt="Screenshot showing clusterssh being used to open multiple terminal windows on Fedora Linux" class="wp-image-3547" srcset="https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-1024x648.png 1024w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-300x190.png 300w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-768x486.png 768w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-420x265.png 420w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min-585x370.png 585w, https://www.putorius.net/wp-content/uploads/2019/10/cssh-diag1-min.png 1167w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></a></figure><p>As you see in the screenshot above, we logged into two machines by running the following command:</p><div class='code-block code-block-8 ai-viewport-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="" data-class="Y29kZS1ibG9jaw=="></div></div><pre class="wp-block-preformatted">cssh savona@fenrir savona@centosdev</pre><p>This can also be shortened like so:</p><pre class="wp-block-preformatted">cssh -l savona fenrir centosdev</pre><p>Cluster SSH then opened two XTerm windows, one for each host supplied as arguments. It also opened an administration console in which you type commands that will be duplicated across the XTerm windows.</p><p>If you would like to enter something into a specific host only, it is as easy as clicking on that window. You can click back into the administration console to resume sending keystrokes to all terminal windows.</p><h2><span class="ez-toc-section" id="connecting-to-groups-of-servers-using-tags">Connecting to Groups of Servers Using Tags</span></h2><p>We already touched on using tags (cluster names) in the configuration section. To connect to systems defined in the clusters file or tags file, simply call cssh and the tag name.</p><pre class="wp-block-preformatted">[savona@putor ~]$ cssh prod</pre><p>NOTE: Tags must be configured in either the clusters file or tags file before use. (See Configuring Cluster SSH Above)</p><h2><span class="ez-toc-section" id="using-the-administration-console-options">Using the Administration Console Options</span></h2><div class="wp-block-image"><figure class="alignleft"><a href="https://www.putorius.net/wp-content/uploads/2019/10/cssh-admin-console1.png" data-slb-active="1" data-slb-asset="1463427979" data-slb-internal="0"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Screenshot of administration console of cssh" class="wp-image-3550" data-lazy-src="https://www.putorius.net/wp-content/uploads/2019/10/cssh-admin-console1.png" /><noscript><img src="https://www.putorius.net/wp-content/uploads/2019/10/cssh-admin-console1.png" alt="Screenshot of administration console of cssh" class="wp-image-3550"/></noscript></a><figcaption>Administration Console for Cluster SSH</figcaption></figure></div><p>There are several menu items across the top of the administration console. They hold some useful options that will increase your Cluster SSH efficiency.</p><div style="height:20px" aria-hidden="true" class="wp-block-spacer"></div><p>In the File menu you will find Show History. It's purpose is obvious, but it's location is very inconspicuous. This will drop a little window down and show you the history of commands typed.</p><div class='code-block code-block-8 ai-viewport-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="" data-class="Y29kZS1ibG9jaw=="></div></div><p>The Hosts menu provides options like "Re-tile Windows" which will re-tile the windows if you moved them, added, or removed hosts. It also has options to make certain windows (or sessions) active or inactive. At the very bottom of this menu there is also a list of currently opened hosts which you can toggle active or inactive. Setting a host to inactive keeps the session open, but anything you type in the admin console will not be sent to that session.</p><p>The Send menu allows you to send things like remote host name, username, random number, etc. These items could be different in each session so this simplifies this action. Optionally this menu can be altered by adding a $HOME/.clusterssh/send_menu file.</p><h2><span class="ez-toc-section" id="using-cssh-command-line-options">Using cssh Command Line Options</span></h2><p>You can use command line options to further personalize your connections. Here are some popular options:</p><h3><span class="ez-toc-section" id="specify-user-on-per-host-basis">Specify User on Per Host Basis</span></h3><p>You can use the -l (--username) option to specify a user to be used.</p><pre class="wp-block-preformatted">cssh -l username host1</pre><p>This comes in handy when you want to quickly connect to multiple systems using a different user account. Simple supply the basic SSH syntax [username]@[host] multiple times, like so:</p><pre class="wp-block-preformatted">cssh savona@putorius ninja@putordb dax@defiant</pre><p>NOTE: Some clusters or tags file configurations can break this functionality. If it is not working as expected, check your files.</p><h3><span class="ez-toc-section" id="run-command-upon-login">Run Command Upon Login</span></h3><p>You can use the -a (--action) option to run a command upon log in. For example, run the who command to see if anyone else is logged in.</p><div class='code-block code-block-8 ai-viewport-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="" data-class="Y29kZS1ibG9jaw=="></div></div><pre class="wp-block-preformatted">cssh -a 'who' host1 host2</pre><h3><span class="ez-toc-section" id="resize-terminal-windows-to-fill-screen">Resize Terminal Windows to Fill Screen</span></h3><p>You can use the --fillscreen option to resize the windows to use the whole screen.</p><pre class="wp-block-preformatted">cssh --fillscreen host1 host2 host3</pre><p>You can find a full list of command line options by using the links in the resources section below.</p><h2><span class="ez-toc-section" id="potential-for-catastrophes">Potential for Catastrophes</span></h2><p>I learned this lesson the hard way so you don't have to. Because of the way Cluster SSH operates when something goes wrong, it usually goes horribly wrong. Remember you are running commands on multiple systems. That means any mistake, mistype or fat finger is being propagated also.</p><blockquote class="wp-block-quote"><p>With great power comes great responsibility.</p><cite>- Voltaire</cite></blockquote><p>Extra special attention should be taken when editing configuration files. Even if you believe the files are the same across all systems, a single comment or blank line can through the line numbers off.</p><p>Be careful, double check your typing and configurations before committing. It is easy to get into trouble.</p><h2><span class="ez-toc-section" id="conclusion">Conclusion</span></h2><p>Cluster SSH is an incredibly powerful tool for system administration. Even now as we move on to tools like Puppet and Ansible for configuration management, I still find uses for good ole cssh.</p><p>In this article we covered most everything you need to get started. We discussed installing and configuring Cluster SSH as well as some usage examples. If you have a comment, question or horror story we would love to hear it in the comments.</p><div class='code-block code-block-8 ai-viewport-3' style='margin: 8px 0; clear: both;'><div class="ai-lazy" data-code="" data-class="Y29kZS1ibG9jaw=="></div></div><h2><span class="ez-toc-section" id="resources-and-links">Resources and Links</span></h2><ul><li><a href="https://linux.die.net/man/1/cssh" target="_blank" rel="noreferrer noopener" aria-label="ClusterSSH Man Page (opens in a new tab)">ClusterSSH Man Page</a></li></ul></div><div class="sh-page-links"></div><div class="post-tags-container"><div class="post-tags"> <a class="post-tags-item post-tags-item-title"> Tags </a> <a href="https://www.putorius.net/tag/server-management" class="post-tags-item"> #server management </a> <a href="https://www.putorius.net/tag/ssh" class="post-tags-item"> #ssh </a> <a href="https://www.putorius.net/tag/system-administration" class="post-tags-item"> #system administration </a></div><div class="sh-clear"></div></div></div><div class="post-switch post-swtich-style2"><div class="row"><div class="col-md-6"> <a href="https://www.putorius.net/llinux-find-last-reboot-time.html" class="post-switch-prev text-left"><div class="post-switch-type">Previous</div><h4> Find Last Reboot Time of Linux System from Command Line</h4> </a></div><div class="col-md-6"> <a href="https://www.putorius.net/dhcping-dhcp-server-troubleshooting.html" class="post-switch-next text-right"><div class="post-switch-type">Next</div><h4> DHCP + PING = DHCPING = Testing DHCP Availability</h4> </a></div></div></div></article><div class="wpdiscuz_top_clearing"></div><div id="comments" class="comments-area"><div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div><h3 id="wc-comment-header"><div class="wpdiscuz-comment-count"><div class="wpd-cc-value">6</div><div class="wpd-cc-arrow"></div></div> Leave a Reply</h3><div id="wpcomm" class="wpdiscuz_unauth wpd-default wpdiscuz_no_avatar"><div class="wpdiscuz-form-top-bar"><div class="wpdiscuz-ftb-left"><div id="wc_show_hide_loggedin_username"></div></div><div class="wpd-clear"></div></div><div class="wc_social_plugin_wrapper"></div><div class="wc-form-wrapper wc-main-form-wrapper" id='wc-main-form-wrapper-0_0'><div class="wpdiscuz-comment-message" style="display: block;"></div><form class="wc_comm_form wc_main_comm_form" method="post" enctype="multipart/form-data"><div class="wc-field-comment"><div class="wpdiscuz-item wc-field-textarea" style="margin-left: 0;"><div class="wpdiscuz-textarea-wrap "><textarea id="wc-textarea-0_0" placeholder="Join the discussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea></div></div><div class="clearfix"></div></div><div class="wc-form-footer" style="display: none;"><div class="wpd-form-row"><div class="wpd-form-col-left"><div class="wpdiscuz-item wc_name-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-user"></i></div> <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title=""></div><div class="wpdiscuz-item wc_email-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-at"></i></div> <input value="" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email"></div></div><div class="wpd-form-col-right"><div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper"><div class="wc-captcha-input"> <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha" class="wpd-field wc_field_captcha" placeholder="Code" title="Insert the CAPTCHA code"></div><div class="wc-label wc-captcha-label"> <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2026'%3E%3C/svg%3E" width="80" height="26" data-lazy-src="https://www.putorius.net/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5e35297421e62" /><noscript><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://www.putorius.net/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5e35297421e62" width="80" height="26"/></noscript></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img alt="refresh" class="" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2016%2016'%3E%3C/svg%3E" width="16" height="16" data-lazy-src="https://www.putorius.net/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" /><noscript><img alt="refresh" class="" src="https://www.putorius.net/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></noscript></a> <input type="hidden" id="c5e35297421e62" class="wpdiscuz-cnonce" name="cnonce" value="c5e35297421e62" /></div><div class="clearfix"></div></div><div class="wc-field-submit"> <label class="wpd_label" title="Notify of new replies to this comment"> <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" /> <span class="wpd_label__text"> <span class="wpd_label__check"> <i class="fas fa-bell wpdicon wpdicon-on"></i> <i class="fas fa-bell-slash wpdicon wpdicon-off"></i> </span> </span> </label> <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Post Comment"></div></div><div class="clearfix"></div></div></div><div class="clearfix"></div> <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id"></form><div class="wpdiscuz-form-bottom-bar"><div class="wpd-clear"></div></div></div><div id="wpdiscuz_hidden_secondary_form" style="display: none;"><div class="wc-form-wrapper wc-secondary-form-wrapper" id='wc-secondary-form-wrapper-wpdiscuzuniqueid' style='display: none;'><div class="wpdiscuz-comment-message" style="display: block;"></div><div class="wc-secondary-forms-social-content"></div><div class="clearfix"></div><form class="wc_comm_form wc-secondary-form-wrapper" method="post" enctype="multipart/form-data"><div class="wc-field-comment"><div class="wpdiscuz-item wc-field-textarea" style="margin-left: 0;"><div class="wpdiscuz-textarea-wrap "><textarea id="wc-textarea-wpdiscuzuniqueid" placeholder="Join the discussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea></div></div><div class="clearfix"></div></div><div class="wc-form-footer" style="display: none;"><div class="wpd-form-row"><div class="wpd-form-col-left"><div class="wpdiscuz-item wc_name-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-user"></i></div> <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title=""></div><div class="wpdiscuz-item wc_email-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-at"></i></div> <input value="" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email"></div></div><div class="wpd-form-col-right"><div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper"><div class="wc-captcha-input"> <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha" class="wpd-field wc_field_captcha" placeholder="Code" title="Insert the CAPTCHA code"></div><div class="wc-label wc-captcha-label"> <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2026'%3E%3C/svg%3E" width="80" height="26" data-lazy-src="https://www.putorius.net/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5e3529742215a" /><noscript><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://www.putorius.net/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5e3529742215a" width="80" height="26"/></noscript></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img alt="refresh" class="" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2016%2016'%3E%3C/svg%3E" width="16" height="16" data-lazy-src="https://www.putorius.net/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" /><noscript><img alt="refresh" class="" src="https://www.putorius.net/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></noscript></a> <input type="hidden" id="c5e3529742215a" class="wpdiscuz-cnonce" name="cnonce" value="c5e3529742215a" /></div><div class="clearfix"></div></div><div class="wc-field-submit"> <label class="wpd_label" title="Notify of new replies to this comment"> <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" /> <span class="wpd_label__text"> <span class="wpd_label__check"> <i class="fas fa-bell wpdicon wpdicon-on"></i> <i class="fas fa-bell-slash wpdicon wpdicon-off"></i> </span> </span> </label> <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Post Comment"></div></div><div class="clearfix"></div></div></div><div class="clearfix"></div> <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id"></form></div></div><div class="wpdiscuz-front-actions"><div class="wpdiscuz-sbs-wrap"> <span><i class="far fa-envelope" aria-hidden="true"></i>&nbsp; Subscribe &nbsp;<i class="fas fa-caret-down" aria-hidden="true"></i></span></div><div class="wpdiscuz-sort-buttons" style="font-size:14px; color: #777;"> <i class="fas fa-caret-up" aria-hidden="true"></i> <span class="wpdiscuz-sort-button wpdiscuz-date-sort-desc ">newest</span> <i class="fas fa-caret-up" aria-hidden="true"></i> <span class="wpdiscuz-sort-button wpdiscuz-date-sort-asc wpdiscuz-sort-button-active">oldest</span></div><div class="clearfix"></div></div><div class="wpdiscuz-subscribe-bar wpdiscuz-hidden"><form action="https://www.putorius.net/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form"><div class="wpdiscuz-subscribe-form-intro">Notify of</div><div class="wpdiscuz-subscribe-form-option" style="width:40%;"> <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType"><option value="post">new follow-up comments</option><option value="all_comment">new replies to my comments</option> </select></div><div class="wpdiscuz-item wpdiscuz-subscribe-form-email"> <input class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email" /></div><div class="wpdiscuz-subscribe-form-button"> <input id="wpdiscuz_subscription_button" type="submit" value="›" name="wpdiscuz_subscription_button" /></div> <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="50ae8213f7" /><input type="hidden" name="_wp_http_referer" value="/cluster-ssh.html" /> <input type="hidden" value="3385" name="wpdiscuzSubscriptionPostId" /></form><div class="wpdiscuz_clear"></div></div><div id="wcThreadWrapper" class="wc-thread-wrapper"><div id="wc-comm-531_0" class="wc-comment wc-blog-guest wc_comment_level-1"><div id="comment-531" class="wc-comment-right wc-hide-avatar"><div class="wc-comment-header"><div class="wc-comment-author ">Laurent Dumont</div><div class="wc-comment-link"><span class="wc-comment-img-link-wrap"><i class="fas fa-link wc-comment-img-link wpf-cta" data-comment-url="https://www.putorius.net/cluster-ssh.html#comment-531" aria-hidden="true"></i></span></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>This is a bit random but a tool like Ansible does replace these kind of hodpge podge ssh clustering solutions.</p></div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Reply"><i class="far fa-comments" aria-hidden="true"></i> Reply</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>October 28, 2019 9:10 AM</div><div class="wc-toggle"><i class="fas fa-chevron-up" title="Hide Replies"></i></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-531_0" class="wpdiscuz_clear"></div><div id="wc-comm-532_531" class="wc-comment wc-reply wc-blog-guest wc_comment_level-2"><div id="comment-532" class="wc-comment-right wc-hide-avatar"><div class="wc-comment-header"><div class="wc-comment-author ">Trish</div><div class="wc-comment-link"><span class="wc-comment-img-link-wrap"><i class="fas fa-link wc-comment-img-link wpf-cta" data-comment-url="https://www.putorius.net/cluster-ssh.html#comment-532" aria-hidden="true"></i></span></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>We use ansible but I can still think of several use cases for cluster SSH. Great article!</p></div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Reply"><i class="far fa-comments" aria-hidden="true"></i> Reply</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>October 28, 2019 3:54 PM</div><div class="wc-toggle"></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-532_531" class="wpdiscuz_clear"></div></div></div><div id="wc-comm-533_0" class="wc-comment wc-blog-guest wc_comment_level-1"><div id="comment-533" class="wc-comment-right wc-hide-avatar"><div class="wc-comment-header"><div class="wc-comment-author ">Josh</div><div class="wc-comment-link"><span class="wc-comment-img-link-wrap"><i class="fas fa-link wc-comment-img-link wpf-cta" data-comment-url="https://www.putorius.net/cluster-ssh.html#comment-533" aria-hidden="true"></i></span></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>I prefer pdsh personally, but good article</p></div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Reply"><i class="far fa-comments" aria-hidden="true"></i> Reply</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>October 28, 2019 10:22 PM</div><div class="wc-toggle"><i class="fas fa-chevron-up" title="Hide Replies"></i></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-533_0" class="wpdiscuz_clear"></div><div id="wc-comm-534_533" class="wc-comment wc-reply wc-blog-guest wc_comment_level-2"><div id="comment-534" class="wc-comment-right wc-hide-avatar"><div class="wc-comment-header"><div class="wc-comment-author ">Aurelien</div><div class="wc-comment-link"><span class="wc-comment-img-link-wrap"><i class="fas fa-link wc-comment-img-link wpf-cta" data-comment-url="https://www.putorius.net/cluster-ssh.html#comment-534" aria-hidden="true"></i></span></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>Clustershell is even better if you like pdsh</p></div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Reply"><i class="far fa-comments" aria-hidden="true"></i> Reply</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>October 29, 2019 3:38 AM</div><div class="wc-toggle"></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-534_533" class="wpdiscuz_clear"></div></div></div><div id="wc-comm-535_0" class="wc-comment wc-blog-guest wc_comment_level-1"><div id="comment-535" class="wc-comment-right wc-hide-avatar"><div class="wc-comment-header"><div class="wc-comment-author ">Anonymous</div><div class="wc-comment-link"><span class="wc-comment-img-link-wrap"><i class="fas fa-link wc-comment-img-link wpf-cta" data-comment-url="https://www.putorius.net/cluster-ssh.html#comment-535" aria-hidden="true"></i></span></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>Securecrt is better one... Anyway these days we have ansible</p></div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Reply"><i class="far fa-comments" aria-hidden="true"></i> Reply</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>October 29, 2019 12:42 PM</div><div class="wc-toggle"><i class="fas fa-chevron-up" title="Hide Replies"></i></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-535_0" class="wpdiscuz_clear"></div><div id="wc-comm-536_535" class="wc-comment wc-reply wc-blog-guest wc_comment_level-2"><div id="comment-536" class="wc-comment-right wc-hide-avatar"><div class="wc-comment-header"><div class="wc-comment-author ">Jose</div><div class="wc-comment-link"><span class="wc-comment-img-link-wrap"><i class="fas fa-link wc-comment-img-link wpf-cta" data-comment-url="https://www.putorius.net/cluster-ssh.html#comment-536" aria-hidden="true"></i></span></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>Secure CRT goes against my values. FOSS!</p></div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Reply"><i class="far fa-comments" aria-hidden="true"></i> Reply</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>October 29, 2019 1:19 PM</div><div class="wc-toggle"></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-536_535" class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-pagination"></div></div><div class="wpdiscuz_clear"></div></div></div><div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"></div></div></div><div id="sidebar" class="sidebar-right"><div class="sidebar-container"><div id="custom_html-5" class="widget_text widget-item widget_custom_html"><div class="textwidget custom-html-widget"><ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-8729877671232535" data-ad-slot="9553892499"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><div id="mc4wp_form_widget-3" class="widget-item widget_mc4wp_form_widget"><div class="sh-widget-title-styling"><h3 class="widget-title">Join Our Newsletter</h3></div><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-2009" method="post" data-id="2009" data-name=""><div class="mc4wp-form-fields"><p> <input type="text" name="NAME" placeholder="Name (Optional)"></p><p> <input type="email" name="EMAIL" placeholder="Email" required=""></p><p> <input type="submit" value="Subscribe"></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1580542324" /><input type="hidden" name="_mc4wp_form_id" value="2009" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2" /><div class="mc4wp-response"></div></form></div><div id="categories-3" class="widget-item widget_categories"><div class="sh-widget-title-styling"><h3 class="widget-title">Categories</h3></div><ul><li class="cat-item cat-item-516"><a href="https://www.putorius.net/category/bash-scripting">Bash Scripting</a> (15)</li><li class="cat-item cat-item-517"><a href="https://www.putorius.net/category/basic-commands">Basic Commands</a> (33)</li><li class="cat-item cat-item-7177"><a href="https://www.putorius.net/category/featured">Featured</a> (6)</li><li class="cat-item cat-item-510"><a href="https://www.putorius.net/category/just-for-fun">Just for Fun</a> (4)</li><li class="cat-item cat-item-508"><a href="https://www.putorius.net/category/linux-quick-tips">Linux Quick Tips</a> (73)</li><li class="cat-item cat-item-504"><a href="https://www.putorius.net/category/linux-tutorials">Linux Tutorials</a> (44)</li><li class="cat-item cat-item-507"><a href="https://www.putorius.net/category/misc-tech">Miscellaneous</a> (7)</li><li class="cat-item cat-item-7333"><a href="https://www.putorius.net/category/network-tools">Network Tools</a> (5)</li><li class="cat-item cat-item-8651"><a href="https://www.putorius.net/category/reviews">Reviews</a> (2)</li><li class="cat-item cat-item-506"><a href="https://www.putorius.net/category/security">Security</a> (19)</li></ul></div></div></div></div></div></div><footer class="sh-footer"><div class="sh-copyrights sh-copyrights-align-left"><div class="container container-padding"><div class="sh-table"><div class="sh-table-cell"><div class="sh-copyrights-info"> <span>© 2010-2020 Putorius - All Rights Reserved</span></div></div><div class="sh-table-cell"><div class="sh-nav-container"><ul id="menu-footer-menu" class="sh-nav"><li id="menu-item-283" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-283"><a href="https://www.putorius.net" data-ps2id-api="true">HOME</a></li><li id="menu-item-531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-531"><a href="https://www.putorius.net/privacy-policy" data-ps2id-api="true">Privacy Policy</a></li><li id="menu-item-2769" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2769"><a href="https://www.putorius.net/about-putorius" data-ps2id-api="true">About</a></li><li id="menu-item-282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-282"><a href="https://www.putorius.net/contact-us" data-ps2id-api="true">CONTACT</a></li><li id="menu-item-407" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-407"><a href="https://www.putorius.net/search" data-ps2id-api="true">SEARCH</a></li><li id="menu-item-2068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2068"><a href="https://www.putorius.net/newsletter" data-ps2id-api="true">Newsletter</a></li><li id="menu-item-3181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3181"><a href="https://www.putorius.net/videos" data-ps2id-api="true">Videos</a></li></ul></div></div></div></div></div></footer></div><div id="login-register" style="display: none;"><div class="sh-login-popup-tabs"><ul class="nav nav-tabs"><li class="active"> <a data-target="#viens" data-toggle="tab">Login</a></li><li> <a data-target="#divi" data-toggle="tab">Register</a></li></ul></div><div class="tab-content"><div class="tab-pane active" id="viens"><div class="sh-login-popup-content sh-login-popup-content-login"><form name="loginform" id="loginform" action="https://www.putorius.net/wp-login.php" method="post"><p class="login-username"> <label for="user_login">Username or Email Address</label> <input type="text" name="log" id="user_login" class="input" value="" size="20" /></p><p class="login-password"> <label for="user_pass">Password</label> <input type="password" name="pwd" id="user_pass" class="input" value="" size="20" /></p> <a href="/wp-login.php?action=lostpassword" class="login-forgot-password">Forgot Password</a><p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p><p class="login-submit"> <input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" /> <input type="hidden" name="redirect_to" value="https://www.putorius.net/cluster-ssh.html" /></p></form></div></div><div class="tab-pane" id="divi"><div class="sh-login-popup-content"><p id="reg_passmail">Registration is closed.</p></div></div></div></div></div> <style type="text/css">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</style><script type='text/javascript'>/* <![CDATA[ */ var mPS2id_params = {"instances":{"mPS2id_instance_0":{"selector":"a[href*='#']:not([href='#'])","autoSelectorMenuLinks":"true","excludeSelector":"a[href^='#tab-'], a[href^='#tabs-'], a[data-toggle]:not([data-toggle='tooltip']), a[data-slide], a[data-vc-tabs], a[data-vc-accordion]","scrollSpeed":800,"autoScrollSpeed":"true","scrollEasing":"easeInOutQuint","scrollingEasing":"easeOutQuint","pageEndSmoothScroll":"true","stopScrollOnUserAction":"false","autoCorrectScroll":"false","layout":"vertical","offset":"110","dummyOffset":"false","highlightSelector":"","clickedClass":"mPS2id-clicked","targetClass":"mPS2id-target","highlightClass":"mPS2id-highlight","forceSingleHighlight":"false","keepHighlightUntilNext":"false","highlightByNextTarget":"false","appendHash":"false","scrollToHash":"true","scrollToHashForAll":"true","scrollToHashDelay":0,"scrollToHashUseElementData":"true","scrollToHashRemoveUrlHash":"false","disablePluginBelow":0,"adminDisplayWidgetsId":"true","adminTinyMCEbuttons":"true","unbindUnrelatedClickEvents":"false","normalizeAnchorPointTargets":"false"}},"total_instances":"1","shortcode_class":"_ps2id"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var wpdiscuzAjaxObj = {"url":"https:\/\/www.putorius.net\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/www.putorius.net\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You&#039;ve already voted for this comment","wc_voting_error":"Voting Error","wc_held_for_moderate":"Comment awaiting moderation","wc_comment_edit_not_possible":"Sorry, this comment no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You&#039;ve not made any changes","wc_new_comment_button_text":"new comment","wc_new_comments_button_text":"new comments","wc_new_reply_button_text":"new reply on your comment","wc_new_replies_button_text":"new replies on your comments","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn&#039;t send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can&#039;t follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":false,"commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"600","liveUpdateGuests":"1","wc_comment_bg_color":"#FEFEFE","wc_reply_bg_color":"#F8F8F8","wpdiscuzCommentsOrder":"asc","wpdiscuzCommentOrderBy":"comment_date_gmt","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"","commentTextMaxLength":null,"storeCommenterData":null,"isCaptchaInSession":true,"isGoodbyeCaptchaActive":false,"socialLoginAgreementCheckbox":0,"enableFbLogin":0,"enableFbShare":0,"facebookAppID":"","facebookUseOAuth2":0,"enableGoogleLogin":0,"googleAppID":"","cookiehash":"641faa547af8bc25a3460be566a14aef","isLoadOnlyParentComments":0,"ahk":"b#k7cw!44ih1%ms2s59(ma6c)qc)lfta","enableDropAnimation":1,"isNativeAjaxEnabled":0,"cookieCommentsSorting":"wpdiscuz_comments_sorting","enableLastVisitCookie":0,"version":"5.3.5","wc_post_id":3385,"loadLastCommentId":0,"lastVisitKey":"wpdiscuz_last_visit","isCookiesEnabled":true,"wc_captcha_show_for_guest":1,"wc_captcha_show_for_members":"0","is_email_field_required":"0"}}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var ezTOC = {"smooth_scroll":"1","scroll_offset":"110"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var mc4wp_forms_config = []; /* ]]> */</script> <!--[if lte IE 9]>
<script type='text/javascript' src='https://www.putorius.net/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.7.4'></script>
<![endif]--> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.putorius.net/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script><script src="https://www.putorius.net/wp-content/cache/min/1/53ec583327bb4996e10fb49c071300d0.js" data-minify="1" defer></script><script type="text/javascript" id="slb_footer">/* <![CDATA[ */ if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB && SLB.has_child('View.init') ) { SLB.View.init({"ui_autofit":true,"ui_animate":false,"slideshow_autostart":false,"slideshow_duration":"6","group_loop":false,"ui_overlay_opacity":"0.9","ui_title_default":true,"theme_default":"slb_black","ui_labels":{"loading":"Loading...","close":"Close","nav_next":"Next","nav_prev":"Previous","slideshow_start":"Start slideshow","slideshow_stop":"Stop slideshow","group_status":"Item %current% of %total%"}}); }
if ( !!window.SLB && SLB.has_child('View.assets') ) { {$.extend(SLB.View.assets, {"2000272948":{"id":3547,"type":"image","internal":true,"source":"https:\/\/www.putorius.net\/wp-content\/uploads\/2019\/10\/cssh-diag1-min.png","title":"cssh-diag1-min","caption":"","description":""},"1463427979":{"id":3550,"type":"image","internal":true,"source":"https:\/\/www.putorius.net\/wp-content\/uploads\/2019\/10\/cssh-admin-console1.png","title":"cssh-admin-console1","caption":"","description":""}});} }
/* THM */
if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_baseline',{"name":"Baseline","parent":"","styles":[{"handle":"base","uri":"https:\/\/www.putorius.net\/wp-content\/plugins\/simple-lightbox\/themes\/baseline\/css\/style.css","deps":[]}],"layout_raw":"<div class=\"slb_container\"><div class=\"slb_content\">{{item.content}}<div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><div class=\"slb_controls\"><span class=\"slb_close\">{{ui.close}}<\/span><span class=\"slb_slideshow\">{{ui.slideshow_control}}<\/span><\/div><div class=\"slb_loading\">{{ui.loading}}<\/div><\/div><div class=\"slb_details\"><div class=\"inner\"><div class=\"slb_data\"><div class=\"slb_data_content\"><span class=\"slb_data_title\">{{item.title}}<\/span><span class=\"slb_group_status\">{{ui.group_status}}<\/span><div class=\"slb_data_desc\">{{item.description}}<\/div><\/div><\/div><div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><\/div><\/div><\/div>"}); }if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_default',{"name":"Default (Light)","parent":"slb_baseline","styles":[{"handle":"base","uri":"https:\/\/www.putorius.net\/wp-content\/plugins\/simple-lightbox\/themes\/default\/css\/style.css","deps":[]}]}); }if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_black',{"name":"Default (Dark)","parent":"slb_default","styles":[{"handle":"base","uri":"https:\/\/www.putorius.net\/wp-content\/plugins\/simple-lightbox\/themes\/black\/css\/style.css","deps":[]}]}); }})})(jQuery);} /* ]]> */</script><script type="text/javascript" id="slb_context">/* <![CDATA[ */ if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);} /* ]]> */</script><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%2C400italic%2C700italic%7CMontserrat%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2Cregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&subset=latin&display=swap" /></noscript><noscript><link rel="stylesheet" href="https://www.putorius.net/wp-content/cache/min/1/6f8828caa1b4bc09dd0f700cd5269d2e.css" data-minify="1" /></noscript></body></html>
